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1. How to start? 

1.1. Start 

1.  Double click on the desktop icon  to start ALTRAview; 
 

2.  Click the Start button (At your screen bottom left corner) and a Start menu will 

bring up. Move your mouse over the menu and try to locate ALTRAview, click to start 

it. 

1.2. Create the camera video window 

ALTRAview will detect all cameras that your computer has installed (Here, it is 

UCMOS03100KPA, a 3.1M pixel CMOS camera) and will append all camera names as 

submenu to the File>Camera List menu (Here, the submenu name is 

άUCMOS03100KPAέ). 

Choosing the File> Came ra List> UCMOS03100 KPA wil l create a video window and 

start  th e video stream. The video window wi ll be associated wit h the nam e of ñVideo 

[ UCMOS03100 KPA]ò ( i.e., its t itl e bar nam e wi ll be ñVideo [ UCMOS03100 KPA]ò).  

There are 3 meth ods to sta rt  the video stream,  they are:  

 

File> Came ra 

List  

Choose th e File>C ame ra List> UCMOS03100 KPA (Here, a 3.1M 

pixel camera is instal led)  command to create the video wi ndow;  

Came ra Sidebar Click the Came ra Sidebar (I f it  is not  act ivated)  and the Came ra 

List  to exp and th e Came ra List  gro up (if not expanded). Click th e 

cam era name (Here it  is UCMOS03100 KPA) to create the video 

window;  
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2. Video window GUI 

2.1. The video window interface 

 
 

A: ALTRAview  

B:  Menu  

C: ALTRAview  toolbar 

D: Camera Sidebar 

E:  Folders Sidebar 

F:  Undo/ Redo Sidebar 
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G:  Layer Sidebar 

H:  Measureme nt  Sidebar 

I :  Measureme nt  Sheet 

J:  Status bar 

K:  Auto Hide but ton 

L:  Hor izontal ruler 

M: Vert ical ruler 

N: Frame  Rate 

O: Frame s captu red 

P: Curr ent  Video sizes 

Q: Selected m icroscope Magnificat ion  

R: Curr ent  Uni t 

AA:  Sidebar r ight  mouse but ton context  menu 

AB:  Video window right  mouse but ton  context  menu 

AC:  Brow se window r ight mouse butt on  cont ext  menu 

AD:  I ma ge window r ight  mouse but ton  context  menu 

AE:  Frame window right  mouse but ton  context  menu 

AF:  Double-click br ing up Video Prop ert ies dialog 

AG:  Double-click br ing up Magnificat ion  dialog 

AH:  Double-click br ing up Measurem ent  dialog 

AI :  Hor izontal Ruler or Verti cal  Ruler r ight  mouse butt on  cont ext  menu 

 

2.2. How to close the video window? 

1.  Double-clicking the tabbed video window title or clicking x on   will 

close the video window directly; 

2.  For MDI video window, click x on   to close the video window;  

3.  Choose the Windows>Close All command to close the video window. 
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3. Image window GUI 

3.1. Image window interface 

 
A: ALTRAview ;   

B:Th e opened file r ight  mous e butt on  conte xt  menu on  statu s bar;  

C:Th e opened file name and directory ;  

D: Double-click br ing up opened file Prop erti es dialog; 

E: Curr ent  image width and height ;  

F:Double-click br ing up Scale Image dialog;  

G: I ma ge Zoom  rat io, double-clicking will zoom the ima ge to 100 % ; 

H: Zoom  rat io r ight  mouse but ton  context  menu;  

I : Curr ent ly selected Unit ;  

J:  Double-click br ing up Measurement  dialog;  
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K: I mage BPP & Resolut ion;  

L: Double-click br ing up Resolut ion  Set ting dialog; 

M: Uni t  r ight  mouse but ton cont ext  menu.  

3.2. How to close the image window? 

1.  Tabbed window 

a)  I f you have modified an ima ge befor e at tem pti ng to close it , double-clicking th e 

tabbed image window t it le or clicki ng x on   will br ing up an ALTRAview  dialog:  

 

 

Clicking Yes wi ll save th e changes wit h its old name and close the wi ndow quickly, No 

wi ll close the file imme diately with no changes and no warning, or Cancel wi ll cancel 

th e Close comm and and leave th e window there wi th no changes;  

b)  I f the I ma ge window is snapped fro m the video window and with number as it s 

tit le,  double-clicking the tabbed im age window t it le or clicking x on   will br ing 

up a  warning ALTRAview  dialog:  

 

Clicking Yes wi ll br ing up the Save As dialog:  
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Select the dr iver and fo lder to which you want your im age file saved in the Save in 

combo box  and enter th e file name in the File nam e edit  box.  

Click Save to save th e captured ima ge with the specified director y and file name , or 

Cancel to close the Save As dialog and retu rn  to image window. 

Clicking No on the ALTRAview  dialog wi ll close the file immediately wi th no changes 

and no warning or Cancel on th e ALTRAview  dialog will cancel the Close comm and and 

retu rn  to image window. 

Note:  Choosing the Window s> Close All comm and can also close the tabbed ima ge 

window. Check the Window s> Close All for detai l. 

2.  MDI  window 

a)  For an opened and modified ima ge window, click X on   to br ing up the 

sam e ALTRAview  dialog. The next  operat ions are just  the sam e as the tabbed wi ndow 

in step 1a;  

b). For a Video captu red ima ge wi th number as its t it le, clicking X on   will 

br ing up the sam e ALTRAview  dialog.  The next  operat ions are just  the sam e as step 1b 

in the tabbed window 

Note:  Choosing the Window s> Close All  command wil l also close the MDI  image 

windows in a quick way. Check th e Window s> Close All  fo r detail . 
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4. UI toolbar 
When the came ra is started or th e image is opened,  most  of the icons on  the toolbar 

wi ll be avai lable for the quick setup of the video or ima ge character ist ic. 

 

 
 

1:  Open (Ctrl +  O) 2:  Save (Ctrl +  S) 3: Quick Save (Quick Save) 

4:  Brow se (Ctrl +  B) 5:  Unit  6:  Magnificat ion  7:  Zoom 

8:  Video/ I ma ge Select  

9:  Track (enabled only when th e video/ ima ge sizes larg e than th e wi ndow size)  

10 :  Object  Select  (wil l be enabled only when an object  exists on th e layer above 

th e backgro und layer)  11 :  Angle 12 :  Point  13:  Line 

14 :  Paral lel 15 :  Two Parallel 16 :  Vert ical 17:  Rectangle 

18 RoundRect  19 :  Ellipse 20 :  Circle 21 : Annulus 

22 :  Two Circles 23 :  Arc 24 :  Text  25 :  Polygo n 

26 :  Calibrat ion  (for  both video/i ma ge wi ndow ) 

27 : Gray Calibrat ion (for video window)  

28 :  Manual Fusion.(for video window)  
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5. Camera Sidebar 
The Came ra Sidebar is used for the control of the ALTRA  came ra, it  includes 12 gro ups. 

The gr oup can be expanded by clicking the gro up name or clicking the Dow n Arro w at 

th e right  of the gro up nam e. 

 

5.1. Camera List 

 

List the cameras connected to the 

computer that support the ALTRAview 

application. Click the camera name to 

start the camera video window.  

5.2. Capture & Resolution group 

 

Snap : Continuously Snap images by 

clicking it;  

Record : Record  video stream in wmv/asf 

or avi format;  

Live : Set the video resolution;  

Snap : Set the Snap  resolution for the 

image capture process.  

5.3. Exposure & Gain group 
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Rectangle for Auto Exposure  

1. When the Exposure & Gain  group is 

expanded  a green rectangle marked with 

ñExposure ò will be overlaid on the video 

This marked region is a reference region 

for judging if the image brightness reach 

to the Exposure Target  value. Drag or 

resize the Exposure ROI  to the dark area 

will increase the video brightness and drag 

it to the brighter area will decrease the 

video brightness;   

2. Uncheck the Auto Exposure box to 

switch the Auto Exposure mode to the 

Manual Exposure . 

The Exposure Target  slider will be disabled in this mode;  

3. Tune the microscope light source to a bright state, and then drag the Exposure 

Time  slider left or right until the image brightness is normal;  

4. If and only if the microscope light intensity is too low to meet the Exposure 

Time  up limit, drag the Gain  slide right until the video brightness is normal;  

5. The exact Exposure Time  can also be entered by clicking the edit box at the 

right of the Exposure Time :. This will bring up a dialog called Exposure Time . You 

can type the number in the field to set the exact Exposure Time  value.  

5.4. White Balance group 

 

 

1. Click the White Balance  bar to expand 

the White Balance  group and a red 

rectangular marked with White Balance  

will be overlaid on the video window;  

2. Drag or resize the red rectangle to a 

pure white or gray area and click the 

White Balance  button to establish the 

video White Balance  for future video 

streaming process;  

3. If the automatic setting and the actual result still has deviation, drag the 
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Temperature  and Tint  slides to left or right to manually correct the White Balance . 

5.5. Color Adjustment group 

 

1. Hue : Adjusts the Hue  of the video. Drag 

the slider to the right to increase or drag 

to the left to decrease hue;  

2. Saturation : Adjusts the Saturation  of 

the video. Drag the slider to the right to 

increase or drag to the left to decrease 

video saturation;  

3. Brightness : Adjusts the video 

Brightness . Drag the slider to the right to 

increase or drag to the left to decrease the 

video brightness;  

4. Contrast : Adjusts the video Contrast . Drag the slider to the right to increase or 

drag to the left to decrease the video contrast;  

5. Gamma : Adjusts the video Gamma . Drag the slider to the right to increase or 

drag to the left to decrease the video gamma;  

6. Defaults : Click the Defaults  to clear all the changes and reset them to default 

ones;  

7. All settings will be saved for future Color Adjustment  application.  

5.6. Frame Rate group 

 

Drag the slider to the right ( High ) to 

ensure that the camera can run the video 

at the fastest Frame Rate  that your 

computer USB hub supports. If the video 

fails to display, drag the slider to the left 

(Low ) to reduce the Frame Rate  and 

enable the video in a low speed mode.  

5.7. Flip group 



Help  Ma nu al   

 
Page 20 of 176 

 

 

If the video on the screen appears in 

different directions from what is viewed 

under the camera, check the ñHorizontal ò 

or ñVertical ò box to set the video direction 

to the right one.  

5.8. Color/Gray group 

 

To preview Color  video, select the ñColorò 

button;  

To preview Gray  video, check the ñGrayò 

button.  

5.9. Power Frequency group 

 

1. A CMOS sensor captures each row of 

pixels (from top to bottom) in sequential 

order, creating a rolling effect, hence the 

name "Rolling Shutter". Instead of being  

relatively constant, so for example, as the commercial main frequency in Europe 

is 50Hz, fluorescent lights in Europe flicker at 100 times per second and as the 

main frequency in US is 60Hz, so in the USA they flicker at 120 times per second;  

2. This flickering problem is solved by captur ing  row pixels over the duration of 

integer number of (n) flicker periods;  

3. check 50HZ  will delete the rolling dark band for the 50HZ  light fluctuation;  

4. check 60HZ  will delete the rolling dark band for the 60HZ  light fluctuation;  

5. For DC power, no light fluctuation exist s and no compensation is needed.  

5.10. Sampling group 

 

1. Bin : Pixel binning refers to the method 

of combining (averaging) pixels of blocks 

of neighboring same color pixels to resize 

the video to a lower resolution;  

2. Skip : Also called "Decimation", means that a certain amount of pixels are not 

read out but skipped (horizontally, vertically or in both axes). This reduces 
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resolution of the resulting video but introduces subsampling artifacts.  

5.11. Histogram group 

 

1. A Histogram illustrates how pixels in an 

image are distributed by graphing the 

number of pixels at each color intensity 

level. The Histogram shows detail in the 

shadows (shown in the left part of the 

histogram), midtones (shown in the 

middle), and highlights (shown in the right 

part). A Histogram can help you determine 

whether an image has enough detail to 

make a good correction;  
2. This group shows the Histogram  of current active video. Two vertical line 

markers show the upper and lower limits of the intensity levels. These markers 

can be dragged with mouse. If you are looking at a color image, the Histogram  

will reflect the RGB (red, green and blue channels histogram at the same time) 

R(red), G(green), and B(blue) values with lines of the same color;  

3. You can also enter directly the desired values in the Left  or Right  boxes below 

the Histogram chart for both  Left and Right Histogram boundaries;  

4. Click the ñRefresh ò button to update the Histogram  display if the sample under 

observation is moved or changed;  

5. Clicking the Defaults  button will return the Left  and Right Histogram  

boundaries to its original ones;   

6. Click the Auto  button to locate the two boundaries automatically to get the 

best video quality.  

5.12. Parameters group 

 

Parameters group is used to save the 

camera control parameters adjusted for 

further application.  

Click Save  will save the current camera 

control parameters with new parameter 

file; The Load  and Overwrite  buttons will 
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be enabled.   

Click Load  will load the saved camera control parameters;  

Click Overwrite  will overwrite the current camera control parameters to the 

current loaded active camera control parameters file;  

Click Management  will invoke a Management  dialog and in this dialog, one can 

manage all of the saved parameter files.   
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6. File 

6.1. Open Image         Ctrl+O 

Choose the File>Op en Ima ge   command to open an exist ing image file.  The 

Open I ma ge command can also be used to preview an ima ge in sm all size,  or to 

view its stat ist ics and infor ma tion  wit hout actual ly opening the ima ge it self. These 

capabilit ies can be used to quickly locate a part icular ima ge. 

ALTRAview  suppor ts and can open m any image for mats.  These are ident ified in th e 

Files of typ e list  box.  You may also open an image file typ e wit h ALTRAview  File Typ e 

( * .tft)  for mat  which has Measurem ent  Obje cts overlaid on the ima ge.  

 

 

More th an one image can be opened withi n ALTRAview  simul taneously by a)  wi th Ctrl  

+  left  mouse butt on  me thod and b)  Shift  +  left  mouse but ton method to highlight  th e 

files to be opened;  

When opening  an image,  ALTRAview  places it  in to a new image window. I t  then 

become s th e active ima ge.  

Note:  ALTRAview  maintain s,  at  th e File>Recent Files subm enu , a lis t  of th e last  4 
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(Can be 1 -8) opened files. Any of these files can be accessed by simply clicking 

on file name. If no files are listed in the File>Recent Files sub menu , th e Open 

Image co mman d must  be used to open th e file . 

Also , the View>Browse ca n be use d to view imag es in an Icon for mat  unde r any 

selecte d director y. Br ief infor mat ion  is given in the View> Brow se me nu . 

File name From thi s list  box, select th e nam e of th e file want  to open. Eith er the 

type of th e file name (with it s ent ire path , if it  is not  in th e current 

fo lder), or selectin g Files of typ e to obtain a list  of file names . 

Double-clicking a file name in the large combo box  (where both fo lder 

and file name s are listed)  will aut oma ti cally open it . 

Note:  I f just  ty pe in th e file name , be sur e th at  th e Files of typ e field 

correctl y identif y th e forma t  of th e file to open. Oth erwise erro r 

mess ages will br ing up when ALTRAview  tries to open th e file. 
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Files of typ e I n thi s list  box, select th e image forma t of the file to open. I f one 

selects All suppo rted for mats, ALTRAview  uses th e file's extension to 

identif y it s forma t. ALTRAview  suppor ts th e fo llowing file formats: 

Window Bitma p(* .bmp,* .dib,* .r le)  

JPEG(* .jpg,* .jpeg,* .jpe,* .j if,* .j fif )  

Por table Network Graphics(* .png)  

Tag I mage File Forma t(* .ti f, * .tiff ) 

Compuserve GIF (* .gif ) 

Targ a(* .t ga)  

PhotoShop(* .psd) 

I CON(* .ico) 

Enhanced Window Metafile(* .emf) 

Window Metafile(* .wmf) 

JBIG (* .jbg)  

Wireless Bitma p(* .wbmp) 

ALTRAview  File Type(* .tft)  

I f th e ima ge file does not  use standard forma t-ident ify ing extensions, 

th e file in th e File nam e field must  be typed, and th en select its forma t 

from th e Files of type list  box. Oth erwise, ALTRAview  will select  a format  

based on the file name extension . 

Preview Click th is but ton to preview image in small size.  I n preview mode, 

stat ist ics and infor mat ion  about the ima ge (i .e. ima ge Width, Height  

and image locati on)  wil l be displayed.  The defaul t  is no Preview. 

Curr ent File Curr ent File locat ion on your computer 

Width Curr ent File image width ;  

Height Curr ent File image height;  

6.2. Open Video  

The File>O pen Video me nu wi ll be enabled only when th ere is no video file opened in 

the ALTRAview  fram e or no came ra start  up. 

1.  Choose the File>O pen Video comm and to open an exist ing video file;  
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2.  Select  the name of th e file you want  to open. I f the file does not  appear, select  

th e opti on  for show ing al l files fr om th e Files of Typ e combo box . The video file type 

can be * .wmv* ; * .asf*  or * .avi*  for mat . 

3.  Click Open to open a video file, th is wi ll create a video window and begin to 

start th e video stream.  The video window wil l be associated a name cal led 

ñVideo [ XXX.XXX]ò (i .e., its tit le bar wi ll display ñVideo [ XXX.XXX]ò, here, 

XXX.XXX is the v ideo file name).  

4.  Click Cancel to return  to th e applicat ion. 

Note:  Only a single video can be opened at  a time.  ALTRAview  takes came ra as an 

special video file,  if the came ra is started, this menu wil l be disabled and the video file 

cannot  be opened anymore.  

6.3. Open Broadcast 

Users could receive the bro adcasti ng video by ALTRAview  fro m th e other user by th e 

I P and por t . For example,  if a user starts a bro adcasting serv ice via I P 192 .168 .0.20 

and port  2080 , th e other users could share the video that  is opened on 192 .168 .0.20 

by inputt ing th e r ight  I P and port. The perfor mance will depend on the bandwidth of 

th e users.  I f the receiver and the bro adcaster are in one intr anet , the perfor mance 

wi ll be excellent . I f not , the perfor mance wi ll depend on the bandwidth. 
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6.4. Camera List 

The File>  Came ra List  submenu will be disabled when th ere is a video file opened in 

th e ALTRAview  frame or a came ra start  up. 

ALTRAview  wil l detect  al l the came ras that  your computer has instal led (Here,  it  is 

UCMOS03100 KPA, a 3.1M pixel CMOS came ra)  and wi ll append al l the came ra name s 

as submenu to the File>C ame ra List  me nu (Here, the submenu nam e is 

ñUCMOS03100 KPAò).  

Choosing the File> Came ra List> UCMOS03100 KPA wil l create a video window and 

start  th e video stream. The video window wi ll be associated wit h the nam e of ñVideo 

[ UCMOS03100 KPA]ò ( i.e., its t itl e bar nam e wi ll be ñVideo [ UCMOS03100 KPA]ò).  

There are 3 meth ods to start  the video stream,  they are:  

File> Came ra 
List  

Choose th e File>C ame ra List> UCMOS03100 KPA 
(Here, a 3.1M pixel camera is instal led)  command to 
create the video wi ndow;  

Camera Sidebar  Click th e Came ra Sidebar (I f it  is not  act ivated) and 
the Came ra List  gro up to expand it  (i f not xpanded). 
Click th e camera nam e (Here  it  is UCMOS03100 KPA) 
to create th e video wi ndow ;  

 

Note:  a) Only a single video can be opened at  a t ime.  ALTRAview  takes came ra as a 

special video file,  if the came ra video wi ndow is opened,  the File>O pen Video 

menu will be disabled and the video file cannot  be opened anymore;  b)  I f a v ideo file 

is opened, the came ra cannot  be started. 

6.5. Twain: Select Device 

Twain is a cross-platfor m  interf ace for acquiring images captured by certain scanners, 

digit al came ras, or fram e grabbers.  The manufactu rer of the Twain Device must 

prov ide a Source Manager and Twain Dat a Source to wor k with ALTRAview . 
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Select  the act ive device for the Twain:  Acquire me nu fro m al l devices avai lable in th e 

device combo box  which are enume rated by the app licat ion. 

One must  instal l the Twain Device hardw are and its dr iver first . See th e 

documentat ion prov ided by th e device manufactu rer fo r  the insta llati on 

instructi ons.  

Before start ing  the Twain:  Acquire th e first  time 

with ALTRAview , choose th e File> Twain:  Select  

Device command first, th is wi ll invoke a dialog 

called Select  Source as shown  below :  

Source:  Choose the right device fro m th e Source 

wi ndow (Highlight  it )  

Select : Click Select  to select the device. U ser does not need to repeat this step for 

subsequent  choosing of the Twain :  Acquire command.  

6.6. Twain: Acquire 

6.6.1. Introduction 

There are basically two techniques used to capture th e video ima ges fro m video 

devices such as a PC camera, digital came ra, and scanner. They are the Twain: 

Acquire technique and th e DirectShow technique (previously cal led VFW).  

The most  obv ious character isti cs of the Twain techn ique is th at  it  pr eviews the video 

in sm aller resolut ion but  captures th e image with higher resolut ion. The USCMOS 

and UHCCD ser ies came ras suppo rt  both  of these two video pr eview techniques.  

6.6.2. Steps for Twain Acquire 

Here we ill ustrate how to capture the image using a UHCCD01400 KPA (1.4M pixels, 

USB2.0)  camera as an exam ple.  

1.  I nsta ll the came ra dr iver (fo r example dr iver for UHCCD01400 KPA hardw are) ;  

2.  I nsta ll ALTRAview ;  

3.  Plug the came ras UHCCD01400K PA (USB2.0) int o the computer;  

4.  Start  ALTRAview ;  

5.  Choose the  File> Twain:  Select  Device  comm and  to  select  the  

device UHCCD01400 KPA fro m  the Select  Source dialog (I f never 
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selected befor e) . 

6.  Choose th e File> Twain: Acquire comm and. There should be a d ialog 

box lik e below:

 

 
I n th is dialog, v ideo Resolu ti on can  be selected (Combo box  if it  has) . The Video 

Source Prop erty can be set  by clicking th e Sett ing but ton. Click the Snap butt on to 

capture an image.  This will create a new wi ndow and it s t itl e bar wi ll be assigned a  

digital as the ima ge wi ndow name;  

Check the RGB/ BGR box to ensure the corr ect  color encoding format  is compatible  

wi th your applicat ion. 

Click X on   to close the Twain:  Acquire  dialog.  

6.7. Save      Ctrl+S 

Choose the File> Save   comm and to imme diately store the curr ent  window image 

to its f ile (the file nam e is listed on  the window's tit le bar)  while leaving the ima ge sti ll 

act ive in it s wi ndow. 

I f th e ima ge is unti t led or t it led wi th a digit , ALTRAview  wi ll issue the File>S ave As 

dialog automat ical ly. The defaul t  ñSave as typeò will be ñWindow Bitm ap 
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( * .bmp,* .dib,* .r le)ò. I f there are Measurem ent  Obje cts overlaid on the im age,  the 

defaul t  Save as type will be ñALTRAview  File Typ e (* .tft )ò. 

The  File> Save comm and can be used to save the most  recent  changes to disk. I t  is 

often perfor me d as a pr ecaut ionary mea sure dur ing lengthy or involved pro cesses to 

reduce the amoun t  of repro cessing th at  m ight  be required in th e event of a system 

fail ure or operat ional erro r. When an ima ge is closed and not  to save its changes is 

chosen, ALTRAview  discard s al l changes made since th e last  File> Save operat ion. 

Note:  a) .The File> Save comm and always saves the cont ents of the ent ire wi ndow, 

even if there is an AOI  (Area of In terest )  defined on it;  b). The File> Save command 

wi ll be disabled if th e file is not  changed or the changes have been saved. 

6.8. Save As 

Choose the File> Save As command to store the contents of the curr ent  window to a  

specified file for mat . At th e end of a File> Save As operation, the ima ge window wi ll 

be associated wit h the new file and the new for mat (i .e., its ti tl e bar wil l display th e 

new file nam e) . ALTRAview  suppor ted file save for mats are:  

Window Bitmap (* .bmp,* .dib,* .r le)  

JPEG (* .jpg,* .jpeg,* .jpe,* .j if,* . j f if )  

Portable Networ k Graphics (* .png)  

Tag I ma ge File Forma t (* .t if, * .t iff )  

Compuserv e GIF (* .gif ) PCX(* .pcx)  

Targa (* .tga)  

JBI G (* .jbg)  

ALTRAview  File Typ e (* .tft)  

Save in:  Find th e folder where th e file wishes to be saved.  A new folder may be 

created using the New Folders but ton. 

File name:  Enter to be saved file nam e. To specify the file's locat ion, eit her enter its 

enti re path (disk and fo lder), or  specify its locat ion using the Save in list  box.  
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Save as typ e:  I n th is list  box,  select  the for mat in which the ima ge wants to be saved. 

Save As is also used to convert  a single ima ge fro m one for mat  to anoth er. For 

exam ple, if a TIFF file needs to convert  to PCX for mat , open the TI FF image first , then 

choose Save As command wi th the PCX for mat  opt ion  to save it  to a new file. 

The defau lt  ñSave as typeò will be ñWindow Bitma p (* .bmp,* .dib,* .r le)ò. I f th ere are 

Measurement Objects over laid on  th e ima ge,  the defaul t  Save as typ e wi ll be 

ñALTRAview  File Type (* .tft)ò. 

The Save As comm and has several impor tant uses beyond simply stor ing an ima ge to 

a new file nam e.  Click Opt ion to select  th e different  param eters to encode the file.  

 

For JPEG (* .jpg ,* .jpeg,* .jpe,* .j if,* .j f if ) , Opt ion has the fo llowing item s:  
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I ma ge qual it y 

I f one save an image in JPEG for mat  (* .jpg ) , one may 

adjust  image quality in th e edit  box. The values range 

from 0 to 100 . Default  value:  75. 

Progr essive The default  is unchecked. 

Optim ize Huffman codes The default  is unchecked. 

Smoothing The values range between 0 and 100. Default  value:  0. 

Save  these  setti ng  as 

defaul ts 

When saving a file, th e cur rent  settin gs will be saved as 

default s for th e next  file save operati on. 

For Por table Networ k Graphics (* .png), Opti on  has the fo llow ing item s:  

 
In ter laced The default  is unchecked. 

Save these sett ing as 

defaul ts 

When saving a file, th e curr ent  settin gs will be saved as 

default s for th e next  file save operati on. 

For Tag I ma ge File Format  (* .ti f, * .t iff ), Opt ion has the fo llow ing item s:  

 
 

App ended pages 

Determine wheth er th e cur rent  ima ge will be saved in mult iple 

pages style or not. 
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Compr essions Specifies a meth od for compressing the composite image data. 

 For saving a 32Άbit  TI FF file, one can specify th at  the file be saved 

with predictor compression, but  have no opti on to use JPEG 

compression. Predicto r compression offers improved 

compression by rearr anging floatin g point  values, and works with 

both LZW and ZI P compression. 

 

Ima ge qual it y 
I f choosing Compressions as "JPEG", th e I mage quality can be 

adjusted by th e slider bar. The values range between 0 and 100. 

Default  value:  75. 

Save these set ting 

as defaults 

When saving a file, th e current  settin gs will be saved as default s 

for th e next  file save operati on. 

For Compuserv e GIF (* .gif ) ;  PCX(* .pcx) ;  Targa(* .tga) ;  JBI G(* .jbg);  ALTRAview  File 

Typ e(* .tft) , There is no Opt ion. 

Note:  a) Detai led infor mat ion  of the above academ ic term inologies can be found 

in book s about  image pro cessing and ima ge compr ession  or internet;  b)  The file 

saved d irector y can be restored for future app licat ion. To keep the director y 

unchanged w hen ALTRAview  is started again,  choose Opt ions> Preferences 

comm and,  click Misc page and check Restore the curr ent director y when startup 

under the Pr ivacy it em.   

 

6.9. Batch Save 

The File> Batch Save me nu will be enabled when a)  an image is opened;  b) an 

image is captured fro m th e came ra;  c) an ima ge window is created by choosing 
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th e File> Paste as New File menu;  d)  an ima ge window is created copied 

fro m the Undo/ Redo Sidebar. 

6.9.1. Batch Save for the a) style image window 

1.  I f the image is modified,  choosing the File> Batch Save command will save th e f ile 

wit h its opened file name and file extension;  

2.  I f the image is modified because of th e Measurement Objects, choosing the 

File> Batch Save menu will save the file wi th its opened file nam e but  wi th 

ñALTRAview  File Type (* .tft)ò f ile extension for mat ;  

6.9.2. Batch Save for the b), c) or d) style image window 

I f the ima ge window has been created wit h b) , c)  or d)  sty le,  choosing the File> Save 

As comm and to realize th e file saving task will be t ime-consum ing.  The Batch 

Save command wi ll runs File> Save As comma nd with the nam e automat ical ly 

specified accord ing to the paradigm  specified in the Batch Save dialog 

To start  the File> Batch Save comm and, you must  

1.  Start  the came ra;  

2.  Snap at least  an ima ge first;  

3.  Choosing the File> Batch Save command wil l br ing up a Batch Save dialog:  

 

Directory :  Ent er the name of the dr ive and director y where your captured im ages wi ll 

be saved.  You may eit her type the path infor mat ion, or use the Brow se but ton to 

locate it  fro m  a standard Brow se Folder dialog.  

Name Format :  The year, month, date, hour, m inute and second or nnnn (sequence)  

are  used to as part  of the file name.  I f more files are saved wit hin a second,  a (xx ) 

suff ix is at tached to the end of Name Format  to avoid the possible nam e conflict . For 
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th e nnnn (sequence)  ñName Formatò, no suff ix is needed. 

File Prefix:  Ent er a file nam e prefix fo r Batch Save when generati ng files name s for a 

ser ies of ima ges. This prefix wil l be combined wi th Name Format  to for m a final file 

name  nam ing paradigm.  

File Typ e:  I n this combo box , select  the for mat  in which you  want  the im age to be 

saved (can be BMP, JPG, PNG, TIF) . Click Opt ion but ton to set  the different 

param eters for encoding the file (For BMP for mat , th e Opt ion wil l be disabled.  See 

File> Save AsÅÅÅ menu about the detai ls of th e for mat  encoding methods) ;  I f there 

are  Measurem ent  Obje cts over th e image,  the File Typ e wi ll be chose as ñALTRAview  

File Typ e (* .t ft )ò by ALTRAview . 

Sam ple:  The final f ile nam e is shown at  the right  of the Sample label fo r reference. 

4,  I f every th ing was finished,  click OK butt on  to begin the file batch save pro cess or  

Cancel to cancel th e File> Batch Save command and retur n to the applicat ion.  

Note:  a)  I n the pro cess of the File> Batch Save command,  the t it le on the ima ge tab 

or image window will be modified with th e file name  forme d in the Batch Save 

dialog.  b)  The File> Batch S ave will perfor m no saving operat ion if the file is not 

modified. 

6.10. Quick Save CTRL+Q 

The File>Q uick Save menu wi ll be enabled when a)an new ima ge captured fro m the 

came ra;  b)an image window is created by choosing th e File> Paste as New File menu. 

File> Quick Save can save the file at  quick way with no need to specify the file 

director y, file name and file for mat. All  those are specified in Options> Preferences, 

Quick Save prop erty page.  The file nam e can be rename d according to th e setup in 

th e Opt ions> Preferences, Quick Save prop erty pageôs Show the rename dialog it em 

6.11. Paste as New File 

The File> Paste as New File me nu wi ll be enabled when th ere is valid image dat a on  
th e clipboard first  (see the Edit>Cop y me nu ). I f there is no  ima ge data on th e 
clipbo ard,  the File> Paste as New File me nu wi ll be disabled. 

Choose the File> Paste as New File command to place the cont ents of the clipbo ard 

image in to a new ima ge wi ndow, which become s the act ive image.  

The new ima ge typ e wil l be the same as that of the or iginal image. ALTRAview  will 

accept  ima ge dat a fro m other applicat ions via the clipboard as long as it  is in 
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Window s Bitma p (DI B)  for mat . 

Note:  ALTRAview  wi ll assign  a digit  to the Paste as New File command created ima ge 

window t it le bar. 

6.12. Print Setup 

Choose the File> Prin t Setup this comm and to access the setup panel fo r the 

pr inter that  has selected.  ALTRAview  wil l pr esent  the standard setu p panel for  th e 

part icular pr in ter (th is is th e sam e panel one would receive if one were sett ing up th e 

pr inter fro m the Window s Control  Panel) . Change pr int er 's setup to satisfy th e 

requirem ents, click OK butt on  to return. 

6.13. Print Preview Ctrl+Shift+P 

Choose the Pr int  Preview command to see the real- t ime effect  of th e pr in ter with out 

actu ally pr int ing it  out. 

6.14. Print Ctrl+P 

Choose th e File> Prin t command to pr int  one or more copies of the curr ent image to 

the selected output device.  The ALTRAview  File> Prin t command lets one take full 

adv antage of the pr inter's capabil it ies. I f the pr inter has bui lt- in half- tonin g or color 

dither ing capabilit ies,  use them or instruct  ALTRAview  to perfor m these pro cesses 

befor e sending the ima ge to the device.  

The File> Print comm and also has facilit ies that  let  one adjust  the size and posit ion of 

the image on the pr in ted page.  

6.15. Recent Files 

ALTRAview  maint ains 4 (defau lt)  most  recent ly opened document  files under th e 

Recent  Files  menu.  Choosing  one  of  these  submenus  wi ll  reopen  that  f ile 

immediately. 
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1.  The ma xim um number of Recent  Files can be modified by choosing the 

Opti ons> Preferences command and clicki ng the Misc page.  Here,  clicking the 4 

(defau lt )  edit  box wi ll allow you  to enter the number of the Recent  Files submenu that 

you  want . The value ranges from 0 to 8, th e defaul t  is 4;  

2.  One can also check the Clear the Recent Files when exit  th e applicat ion  to clear th e 

Recent  Files after  exit  ALTRAview  applicat ion. 

6.16. Exit 

Choosing the File> Exit  command wi ll close video, all of th e image window s and 

Brow se wi ndow and rem ove their  window s fro m the screen. After al l of the window s 

are  closed, ALTRAview  wi ll end itself. 

Note:  I f an ima ge has been modified befor e at tempti ng to Exit  it , ALTRAview  wil l issue 

a warning to ask if user want  to save the ima ge or not  f irst. 
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7. Edit 

7.1. Undo/Redo Ctrl+Z 

I f the I ma ge or Processing me nuôs submenu command is exerted on the ima ge, the  

Edit> Undo menu wil l be enabled. 

Most  of the operati ons in ALTRAview  can be undone.  Alternat ively, one can restore al l 

or part  of an im age to its last  saved version. The basic Undo dem o pro cess is:  

1.  Choose the File> Open Image command to open an image;  

2.  Choosing the Ima ge>Ad just>A uto Level command, then the Edit> Undo menu wil l 

be enabled;  

 
 

3.  Choosing the Edit> Undo command will cancel th e Ima ge>A uto Level operat ion 

and retu rn  th e Operat ion  to its ini t ial opened sta te. 

 
 

I f return to the Edit  me nu , one will find that  the Edit> Undo menu now is changed to 

Edit> Redo. You  can select  one of these two operat ions to understand th e Undo and 

Redo mechanism s:  

1.  Choosing the Edit> Redo command will return the ima ge to the I ma ge> Auto Level 

Operat ion and the Edit> Undo menu wil l be enabled again;  

2.  Choosing th e I ma ge>A uto Cont rast  command, then th e Edit> Redo menu wil l 

change to Edit> Undo;  
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Note:  ALTRAview  suppo rts only one step Undo and Redo operat ions.  

7.2. Forward 

The Edit> Forward menu wil l be enabled if it  is not  in the final step in the Undo/ Redo 

Sidebar. 

The Edit> Backward me nu wi ll be enabled if it  is not  in the first  step in the Undo/ Redo 

Sidebar. 

The Edit> Forward command wi ll forw ard the curr ent  displayed image to the next 

operat ion listed in th e Undo/ Redo Sidebar (I f it  is not  in th e fina l step) . 

7.2.1. Forward Demo 

1.  Open an image,  choose the I ma ge>A djust> Auto Level and th e 

I ma ge> Adjust> I nvert  comma nds;  check Curr ent  on I ndex 1 (Open Operati on). 

The Undo/ Redo Sidebar is shown below in Fig.1 

 

Now we continue th e Edit> Forw ard menu demo. Since it  is in I ndex 1, the 

Edit> Backw ard menu is disabled and the Edit> Forward menu is enabled. 

2.  Choosing the Edit> Forw ard com mand, the ima ge and the I ndex will Forw ard to 

Fig.2.  Now th e Edit> Backw ard menu is enabled;  
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3.  Choose the Edit> Forward menu again to go to I ndex 3 as shown in Fig 3. Now th e 

Edit> Backw ard me nu is stil l enabled,  but because it  is in the final operat ion, th e 

Edit> Forw ard menu is disabled.  

See Edit> Backw ard for further infor mati on. 

7.3. Backward 

The Edit> Forward menu wil l be enabled if it  is not  the final operat ion  in th e 

Undo/ Redo Sidebar. 

The Edit> Backw ard menu wi ll be enabled if it  is not  the first  operat ion  in th e 

Undo/ Redo Sidebar. 

The Edit> Backward command wi ll move the curr ent displayed image to the pr evious 

I ndex listed in th e Undo/ Redo Sidebar (I f it  is not  in th e "Open" sta tus) . 

7.3.1. Backward Demo 

1.  Choose the Open Ima ge command to open an ima ge;  

2.  Exert  th e I m age>Ad just> Auto Level command on the ima ge;  

3.  Choose the I ma ge>A djust> I nvert  comm and, the final image is shown  in Fig 3. 

Since it  is in the final operation state (Fig.3) , the Edit> Backward menu will be 

enabled;  

4.  Choosing the Edit> Backward com mand, the ima ge and the I ndex wi ll Backw ard to 

I ndex 2 as shown in Fig 2. Since it  is in I ndex 2, th e Edit> Forw ard menu will be 

enabled;  

5.  Choosing th e Edit> Backw ard command again, both th e ima ge and the I ndex will 

Backw ard to I ndex 1 as shown  in Fig.1.  Since it  is in I ndex 1,  the Edit> Forward menu 

wi ll sti ll be enabled,  but  the Edit> Backward menu wil l be disabled.  

See Edit> Forward for fur th er infor mat ion. 
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7.4. Cut     Ctrl+X 

The Edit> Cut me nu wil l be enabled only when an Object  or Objects on the Layer over 

th e image is or are selected.  

Check the Measurem ents>Ob je ct  Select    or Edit>S elect  All menu about  how 

to select  Layer objects for th e Edit>C ut  menu functi on. 

Choose the Edit> Cut  comm and to copy th e selected Measurement  Obje cts to the 

clipbo ard and delete the selected Obje cts on  the ima ge.  Any dat a already exist  on  the 

clipbo ard will be replaced. 

The dat a copied to th e clipbo ard can be pasted int o th e act ive window or int o anoth er 

opened video/ image window on  the layer above th e image using th e Edit> Paste 

command (when there is no Layer over the Backgro und, create a new Layer wit h th e 

Layer> New command first ) . 

Note:  The Edit>C ut  comm and does not  suppor t  Backgr ound Layer (ima ge)  Cut  

operat ion. 

7.5. Copy    Ctrl+C 

When the Measurem ent Object( s)  is (are)  highlighted, the Edit>Cop y menu w ill be 
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enabled.  

When an image ROI  is selected and the Curr ent  Layer is the Backgro und Layer, the 

Edit>Cop y menu wi ll be enabled.  

Choose th e Edit>Cop y comma nd to Copy the highlighed Obje cts (on Measurem ent 

Layer)  or an im age's selected area on the Backgro und Layer to the clipbo ard.  

Copy the selected area on the background layer to the clipboard.  

1.  Select  the ima ge area using the Ima ge Select    butt on  on  the toolbar. The 

Edit> Copy menu wi ll be enabled;  

2.  Choose th e Edit>Cop y command to copy the selected ima ge area to the clipboard. 

Cop y  ob je ct ( s)  on  th e mea sur em en t  layer  t o  t he  cl ipbo ar d.  

1.  For the Layer operat ion, see the View>S idebar> Layer menu in Sec.8 and the 

Layer menu in Sec.13 for details;  

2.  For th e Measurement  operat ion, see the View> Sidebar> Measurement  menu in 

Sec.8 and th e Measurements menu in Sec.14 ;  

3.  After the Measureme nt  operat ing has been done, choose Measurements>O bjec t 

Select  command or check the Object  Select  but ton   , the cursor wi ll change to ;  

4.  Move the mouse un til the cursor become s , th is means the cursor is r ight  on 

th e Object . Clicking it  wil l highlight  Obje ct  and select  the Object ;  

5.  Opt ion 1: Conti nue to move the mouse unt il the cursor becomes   again, 

this means the cursor is r ight  on  anoth er Obje ct  again . Clicking it  with SHI FT+ left  

mouse but ton  and the second Object  will be selected and highl ight ed;  

6.  Opt ion 2:  a)  Move the cursor over the ima ge, click dow n the left  mouse butt on;  b) 

Drag the mouse to draw a recta ngle on the ima ge.  A dot ted rectangle will appear 

around th e selected area;  c)  Release the mouse and all of the Measurem ent  Obje cts 

withi n the dot ted rectangle will be highlighted and selected;  

7.  After the Measureme nt  Obje cts are selected,  th e Edit>Cop y menu wil l be enabled;  
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8.  Choose the Edit>Cop y to Copy the Obje ct(s)  to the clipbo ard.  Then the Edit> Paste 

menu wil l be enabled. One can th en Paste the objects ont o the Curr ent Layer or ont o 

th e oth er Measurement  Layer in th e sam e video/ image window. I f one switches to 

th e Backgro und Layer, the Edit> Paste menu wil l be disabled, but  if one returns to the 

Measurement  Layer, the Edit> Paste menu wi ll be enabled again . 

Note:  a) The Edit>Cop y comm and will not  delete the Measurem ent  Objects over th e 

image. Any data existing on the clipbo ard wi ll be replaced with the new dat a;  b)  The 

copied Object (s)  can be pasted into the act ive window or in to another opened 

window using the Edit> Paste command as long as th e curr ent  wi ndow is not  on th e 

Backgro und Layer ( the Edit> Paste me nu will be disabled if the Backgr ound Layer is 

act ive) . See the View> Sidebar> Layer comm and in Sec.8 and the Layer me nu in 

Sec.13 for details. 

7.6. Paste     Ctrl+V 

I f there is Measurem ent Object  data in th e clipbo ard and the Curr ent  Layer is not  th e 
Backgro und Layer, the Edit> Paste menu wi ll be enabled.  

Choose the Edit> Paste comma nd to Paste Objects fro m the clipbo ard ont o th e active 

image's Measureme nt  Layer. One can also choose Edit> Paste command to tr ansfer a 

layer's Measureme nt  Objects fro m one ima ge window's Measurement  Layer to 

another image window's Measurem ent  Layer. 

Note:  The Edit> Paste command does not  support  the ima ge area Paste operat ion. 

7.7. Image Select    

The Edit> I mage Select  command can be used to ma rk ROI  and Copy th e selected 

ROI  to th e clipboard . This command is only used to select  the ROI  on th e Backgro und 

Layer. 

Choosing the Edit> I ma ge Select  command wi ll check this menu (or click   on 
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the toolbar wil l keep it  down) and the cursor will turn into  ñ ò. After th e area is 

selected and the Curr ent Layer is the Backgr ound Layer, the Edit>Cop y menu wi ll be 

enabled and then the selected area can be copied to the clipboard for further 

applicat ion.  

To select  an area, 

1.  Choose Edit> I ma ge Select  com mand (Or click the I ma ge Select  but ton   on the 

toolbar)  

2.  Drag th e mouse cursor across the image wi th the left  but ton held down  unti l the 

area is selected.  

3.  Release the butt on  and the area wi ll be ma rked. Handles wi ll appear on th e area 

tha t  wil l al low altering the select ion after it  is ma rked.  

 
 

Note:  Only when a ROI  is selected and the Curr ent  item  is checked on the 

Backgro und in the Layer Sidebar, the Edit>Cop y comm and can copy the selected 

image ROI  to the clipboard . 

7.8. Select All Ctrl+A 

7.8.1. Select All on the background layer 

When the video/ image window is active and the Backgro und Layer is checked, 

choosing the Select  All command to select  all pixels on the Backgro und layer with in 

th e canvas (shor tcut :  Ctr l+ A).  

7.8.2. Select All objects over the background layer 

When the video/ ima ge window is act ive and the Backgro und Layer is not  checked, 

choosing the Edit>S elect  All command wi ll select  all of the Objects on  th e Curr ent  

Layer (shortcut :  Ctrl+ A).  
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7.8.3. Select all files in the browse window 

When the Brow se window is acti ve,  choosing the Edit>S elect  All  command wi ll select 

al l of the files in the Brow se window under the specified directory in the Folders 

Sidebar. See Edit> I nvert  Select ion  for select  al l files method.  

7.8.4. Select None Ctrl+D 

Deselect  any selected area on th e image or the Measureme nt Objects on a Layer. 

1.  When the Curr ent  Layer is the Backgro und Layer and an image area is selected, 

th e Select  None menu wi ll be enabled.  Choosing the Edit> Select  None comm and will 

delete th e dot ted rectangle repr esent ing the selected area;  

2.  When the Curr ent  Layer is not  the Backgr ound Layer and the Measurem ent 

Objects are selected,  the Edit>S elect  None command wi ll be enabled. Choosing the 

Edit>S elect  None command will deselect  al l of the selected Measurem ent  Objects. 

Note:  See Edit> I mage Select, Edit>S elect  All and Measurem ents>Ob ject Select   

to understand how to perfor m  select  operat ions. 

7.9. Inverse Selection 

This command is for Brow se window only. 

When org an izing files,  one can inv ert  a selecti on  in ord er to select  all of th e other files 

tha t  were not  previously  selected wi th the Edit> I nvert  Select ion  command. 

When no files were selected,  choosing the Edit> I nvert  Select ion command will select 

al l of files under the Folders Sidebar director y which is just  as the Edit> Select All 

command.  

7.10. Delete File Delete 

The Edit>D elete File menu will be enabled if the file(s)  is (are)  highlighted in the 

Brow se wi ndow. This command is for  Brow se window only. 

You can Delete or rem ove one or more files fro m the Brow se window. The steps are 

as fo llows:  

1.  Select  one or more files by a)  Clicking th e displayed file icons, a single file will be 

highl ighted;  b)  Clicking the file one by one wit h CTRL +  left  mouse but ton, all th e 

clicked files wi ll be highlighted;  c)  Clicking the displayed file icons,  the first  clicked file 
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wi ll be highlighted, clicking the end file wit h Shift  +  left  mouse butt on , al l of th e files 

among the first  and last  wi ll be highl ighted.  d)  Dragging the mouse to draw a dot ted 

line rectangle across the files you  wish to delete, al l of the files in the rectangle wi ll be 

highl ighted;  

2.  a)  Press the Delete key to delete the selected files;  b)  Click you right  mouse but ton 

to br ing up a context menu, choose the Delete comm and to delete the highlight ed 

files. A Confirm  File Delete dialog will br ing up. 

I n th e Confirm  File Delete dialog, click Yes to move th e files to the deskto p recycle bin, 

or No to cancel the Delete operat ion. 
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8. View 

8.1. Browse         Ctrl+B 

8.1.1. Open the browse window 

1.  Choose the View> Brow se menu fro m the View menu or click the Brow se toolbar 

but ton    to brow se ima ges under th e specified directory in th e Folders Sidebar;  

2.  Click th e Folders Sidebar to act ivate it  and double-clicking th e listed directory in 

th e Folders Sidebar wil l create th e Brow se window. 

After creati ng th e Brow se wi ndow, ALTRAview  wil l display a Browse window that  look s 

like window s explorer. The chi ld window on the left  part  of th e Brow se window called 

Folders Sidebar is used to locate the directory on  the hard disk. I ma ges in the curr ent 

directory are displayed in Large I cons or Small I cons mode on the right side of th e 

Brow se wi ndow. 

Their  ord er can be set  in Forw ard or Reverse for mat  according to Sor t  by Nam e, Typ e, 

Size, Width or Height  et al. 

8.1.2. Browse window right mouse button context menu 

Clicking th e r ight  mouse butt on on the listed I con in the Brow se wi ndow wil l br ing up 

a r ight  mouse butt on  context menu as shown  below:  

 

 
 

These context  menu funct ions are  descr ibed in 

View> Delete File 

View>So rt> Sor t  by Name s 

View>So rt> Sor t  by Typ e 

View>So rt> Sor t  by Size 

View>So rt> Sor t  by Width 

View>Sort >Sor t by Height  
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View>So rt> Forward 

View>So rt> Reverse 

View> I con> Larg e I cons 

View> I con> Small I cons 

View> Refr esh for detai ls 

Note:  The Folders  Sidebar and the Brow se can be used to perfor m  tasks such as 

creati ng new fo lders, renam ing, mov ing,  and delet ing files. I ndividual f ile 

infor mati on  and impor t  data fro m digita l cameras can also be displayed. 

Double-clicking the left  mouse but ton on th e icon  wil l open the image as an act ive 

image in ful l size.  See Ima ge window UI in Sec.3 for more detai ls.  

8.2. Measurement Sheet 

When choosing th e View>M easurem ent  Sheet  comm and,  the Measurem ent  Sheet 

wi ll be act ive.  The Measureme nt  Sheet  shows the Obje ct's possible features, such as 

Name, Center, Radius, Area, Per imeter, Angle, Start  Point , and End Poin t  overlaid on 

th e extr a layer. 

 
 

Clicking the r ight  mouse but ton on  th e Measurem ent  Sheet and the r ight  mouse 

context  menu will br ing up on th e Measurem ent  Sheet window as shown above. 

They are exp lained below:  
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8.2.1. File Import 

Choose th is command to load a Measurem ent  files (* .me asurem ent )  and over lay the 

Measurement  Objects over the curr ent v ideo/ image backgro und. 

8.2.2. File Save 

Choose this command to save the Measureme nt  Objects over the curr ent  

video/ image on the Curr ent  Layer to a Measurement  files (* .measurem ent) . 

8.2.3. Export>To Html File 

Expor t  al l th e Layer Measurement  Objects to the * .h tml  file in tabbed for mat . 

 

Note:  This menu will be enabled only when there are Measurem ent  Objects over the 

Backgro und Layer (v ideo/ ima ge) . 

8.2.4. Export to Excel 

I f this command is chosen, th e Curr ent  Layer Measurement  Objec ts over th e 

video/ image wi ll be expor ted to Microsof t  Excel. The Objects' parameters in th e 

Measurement  Sheet  wil l also be arranged as a table.  

 

Note: This menu wi ll be enabled only when there are  Measurement  Obje cts on th e 

Curr ent Layer (v ideo/ ima ge) . 

8.2.5. Auto Highlight 

When this me nu is checked,  clicking th e row in the Measurement  Sheet  will Highlight 

th e corr esponding Measureme nt  Obje ct  over th e Backgro und Layer. Clicking th e 

Object  over th e video/ ima ge will Highlight  the corr esponding row in the 

Measurement  Sheet. 

8.2.6. Settings 
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1.  To modify  the Measureme nt  Sheetôs item  ord er, click the item to highl ight  it , th e Up 

or Dow n butt on  wil l be enabled (I f the item  is in the third posit ion, the Up butt on  

wil l be disabled, if the it em  is in the last  row, the Down  but ton  wil l be disabled) . 

Click th e Up or Dow n but ton  to modify the item  ord er;  

Note:  The it em  I ndex and Name are always in gr ayed states,  this means th ese two 

it em s cannot  be modified (Both their  hide/ show sta tes and their  posit ions) . 

2.  Checking/ Unchecking the item  will show/ hide the item  in the Measurem ent Sheet;  

3.  Clicking Defaul t  wil l retu rn  to th e ALTRAview 's default  sett ings;  

4.  I tem  1(I ndex) and item  2(Name)  cannot  be changed.  

8.3. Sort 

8.3.1. Sort>Sort by Names 

This command is for the Brow se wi ndow only. 

Sort  the ima ge files in ord er of nam es in th e Brow se window. 

8.3.2. Sort>Sort by Type 

This command is for the Brow se wi ndow only. 

Sort  the ima ge files in ord er of typ e in the Brow se wi ndow. 
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8.3.3. Sort>Sort by Size 

This command is for the Brow se wi ndow only. 

Sort  the ima ge files in ord er of size in the Brow se window. 

8.3.4. Sort>Sort by Width 

This comm and is for the Browse window only.  

Sort the  image  files in ord er of ima ge width in the Brow se window. 

8.3.5. Sort>Sort by Height 

This comm and is for the Browse window only.  

Sort the image  files in ord er of ima ge height  in the Brow se window. 

8.3.6. Sort>Ascending 

This com mand is  for t he Browse window only.  

Sort  the image files in ord er of th e Ascending mode (i.e.  1,  2, 3 and 4)  in the Brow se 

window. 

8.3.7. Sort>Descending 

This command is for the Browse window only.  

Sort the image files in order of the Descending mode (i.e. 4, 3, 2 and 1) in the 

Browse  window.  

The Sort settings  are saved until they are changed. For example, if you sort images in 

the  Brow se window according to th e Type, th e images will remain sorted accord ing to 

Typ e unti l th e Sor t  settin gs are changed. 

8.4. Icon 

8.4.1. Icon>Large Icons 

This command is for the Browse wi ndo w only . 

The Thumbnail mod e display s sm all pre view image s;y ou  can select  differ ent  vie w 

mod es in th e Browse wi ndow . 

Choosing the Icons > Larg e Icons wi ll display the ima ge files in Larg e I con mode in th e 

Brow se wi ndow. 
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8.4.2. Icon>Small Icons 

This command  is for the Brow se wi ndow only. 

The Thumbnail m ode displa ys small pr eview images; you can select di ff erent view 

modes in the Browse win dow.  

Choosing the Icons>Small Icons will display the ima ge files in Small Icon m ode in the  

Browse  wi ndow. 

8.5. Refresh F5 

This command is for the Browse win dow only.  

If the files under the Folders Sidebarôs direct or y a re alte red outsi de of ALTRAview , 

after s witch back to ALTRAview , one can Refresh the ima ge files in the cu rr ent 

direct or y to update the Thumbnai ls wit h View> Refr esh comm and.  

8.6. Sidebar 

There are 5 Sidebar in the ALTRAview  fram e window in tabbed for mat.  They are 

Came ra Sidebar, Folders Sidebar, Undo/ Redo Sidebar, Layer Sidebar and 

Measurement  Sidebar. 

8.6.1. Sidebar overview 

 
AA:  Camera Sidebar;  AB:  Came ra Sidebar gr oups for the cont rol  of the started up 

came ra. 

BA:  Folders Sidebar;  BB:  Back to the pr evious fo lder; BC:  Forw ard to th e next  fo lder;  

BD:  Brow sing the pictures under th e director y of ALTRAviewôs directory;  BE:  Auto hide 

but ton to show/ hide the curr ent  selected directory, th is wil l open th e Brow se window 

if it  is not  opened (Double-clicking on th e selected directory will perfor m th e same  

funct ions.) ;  BF:  Folders  to locate the Browse  windowôs file directory. 
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CA: U ndo/Redo Sidebar;  CB:  Operat ion Copy :  Copy th e highl ighted operat ion  in the 

Undo/Redo Sidebar to a new image wi ndow ;  User can also drag the selected 

operat ion  in the Undo/ Redo S idebar to the wi ndow area to create a new ima ge 

wi ndow ;  CC:  Rem ove th e highl ighted operat ions fro m the Undo/ Redo list  (This but ton 

wi ll be e nabled only when the operation(s)  is (are)  selected, the opened image(t he 

first operat ion)  cannot  be rem oved;  CD:  I ndicating the Curr ent  operat ion displayed in 

the ima ge window; C E:  Operat ion  I ndex;  CF:  Operat ion  nam e.  

DA:  Layer Sidebar;  DB:  Make a New layer;    DC:  Rem ove a layer;  DD:  Set  as the 

Curr ent layer;   DE:  Show/H ide a layer;  DF:  Renam e a layer; DG:  Visibil it y control  

of the layer item s;  DH:  The Curr ent  acti ve layer for operations ;  DI :  The layer Nam e. 

The image layer is always name d as ñBackg roundò. 

EA:  Measurement  Sidebar;  EB:  The App earance of th e highl ighted Object  on the 

Curr ent  layer;  you  can edit  th e App earance by clicking its item and edit ing it;  EC:  The 

Calculat ion  of the highl ighted item  on th e Curr ent layer;  ED:  The Coor dina te of th e 

highl ighted item on the Curr ent  layer; you c an edit  th e Coord inate by clicking the 

item . 

8.6.2. Sidebar>Camera 

The Camera Sidebar is mainly used for the control of ALTRA series came ras, and  

includes 11 gro ups. Every group can be expanded by clicking the gro up nam e 

or th e arro w b ut ton  at the r ight  of the group nam e. 

Checking the Sidebar>C ame ra menu wil l act ivate/ show it  on th e fram e. 

Please check Came ra Sidebar in Sec.5 for detai ls.  

8.6.3. Sidebar>Folders 

The Folders Sidebar is mainly used for ima ge Brow se control. 

Checking the View> Sidebar> Folders menu wi ll act ivate/ show the Folders Sidebar. 

Clicking its tree can  navigate the file director ies. 

Double-clicking th e director y in the Folders wil l create the Brow se window. I f th ere 

are  ima ge files under th e tree tha t  ALTRAview  suppor ts to brow se,  the ima ge files wil l 

be displayed in Large or Small icons mode.  

Their  ord er can be set  in Forw ard or Reverse for mat  according to Sor t  by Nam e, Typ e, 

Size, Width or Height  et al. 

Clicking wit h the right mouse but ton on the director y will br ing up the right mouse 
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context  menu as shown  below:  

 
This is the basic window exp lorer menu and wil l not  exp lain it  here in this m anu al. 

8.6.4. Sidebar>Undo/Redo 

The Undo/ Redo Sidebar is used to Undo/ Redo operati ons for th e Ima ge and Process 

menusô comm and.  

Checking the View> Sidebar> Undo/ Redo menu wi ll activ ate/ show the Undo/ Redo 

Sidebar. 

8.6.5. Sidebar>Layer 

Layer Sidebar is used for the management  of Layer operat ions.  This operati ons 

including ma king a New Layer, Rem ov ing a Layer or Renaming a Layer and Layer 

visibil it y cont roll ing et  al. 

Checking View> Sidebar>  Layer will act ivate/ show the Layer Sidebar. 

8.6.6. Sidebar>Measurement 

The Measurem ent Sidebar is used to check or edit  the selected Layer Obje cts on th e 

Layer. 

Checking View> Sidebar> Measureme nt wi ll act ivate/ show the Measurem ent 

Sidebar. 

I n th is sidebar, the Obje ct  App earance, Calculat ion and Coordinates character isti c 

are  listed.  The App earance and Coord inates can be edited. 
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8.7. Ruler and Grid 

Ruler and Grid menu has 3 submenus, they are:  

8.7.1. Grids>No Grids 

Choosing this command wi ll rem ove both Manual Grids and Auto Grids overlaid on 

th e video/ image window. 

8.7.2. Grids>Manual Grids 

Choosing th is comma nd will display two sma ll Right  Arro w and Dow n Arro w overlaid 

on  the top of the Vertical Ruler and on the left  of th e Horizontal Ruler as shown 

below:  

 

Move th e mouse over the Down  Arro w wi ll show a hor izont al drag icon. Drag the 

Dow n Arro w along the Hor izonta l Ruler to wherever  you want . When it  is dragging 

over the video/ image,  there will be a Vert ical line appearing  to let  you  judge where to 

release this line on the video/ image.  You can drag any lines to over lay them on th e 

video/ image.  

The overlaid lines can  be adjusted by dragging the specific Dow n Arro w again on 

Horizonta l Ruler. 

Move the mouse over  th e Right  Arro w wil l show a vert ical drag icon. Drag the Right 

Arro w along the Horizontal Ruler to wherever  you  want. When it  is dragg ing over 

th e video/ image, there wi ll be a Hor izontal line appeared to let  you  judge where to 

release this line on the video/ image.  You can drag any lines to over lay them on th e 
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video/ image.  

The overlaid lines  can be adjusted by dragg ing the specific Right  Arro w again on 

Verti cal  Ruler. 

 
Choose the Gr ids> No Grid command to rem ove the Manual Grids overlaid on th e 

video/ ima ge wi ndow. The menu wil l be checked.  

Choose the Grids>M anual Grids command again (I f it  is unchecked)  to display all the 

pr evious Manual Grids overlaid on th e video/ ima ge window. The menu will be 

checked. 

8.7.3. Grids>Auto Grids 

Choose the Gr ids>A uto Grids command to overlay th e gr ids on th e video/ image 

aut oma ti cally.  

The Auto Grids can be set in the Ruler and Grids>S ett ing menu. 

8.7.4. Grids>Remove All Grids 

Remove (Delete ) al l the Manua l Grids or Auto Grids overlaid on the ima ge/ video 

window. 

8.7.5. Settings 

Choosing  the View>R uler and Grid> Sett ing command, or choosing th e 

Preference>  comm and and clicking the Rulers and Grids page real ize th e sam e 

funct ion. 
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Choosing the Preference> command and clicking  the Rulers and Grids page can set  

Ruler Color, Cursor Color of th e Hor izont al Ruler and Verti cal Ruler fo r the video or 

image windows. The Grid Style, Line Style, and Line Color fo r the Grid over laid on  th e 

video and ima ge wi ndow can also be set . 

 

Ruler Color :  The Hor izontal Ruler color  and Vertical Ruler color ;  Defau lt  is blue 

(0,0,255 ) ;  

Cursor Color :  The Cursor color ;  When you  are mov ing your mouse over the 

video/ image window, there wil l be Horizontal Cursor and Vert ical Cursor move on th e 

Horizonta l Ruler and Verti cal  Ruler mov ing at the same t ime indicating the curr ent 

Cursor posit ion in both direct ions.  Defaul t  is Red (255 ,0,0) ;  

Gr id Style:  The Grid Style can be No Grid, Auto Grid or Manua l Grid. Defaul t  is No 

Grid;  

Gr id Line Style:  The Line Style for the gr id can be Solid, Dash, Dot  or DashDot  et al. 

Defau lt  is Solid;  

Gr id Line Color :  The color of the gr id line.  Defaul t  is Red (25 5,0,0) . 

8.8. Best Fit 

Choose th e View> Best  Fit  command to automat ically resize the video / image to fit  in 

th e window. 

Note:  Choosing th is command wi ll enable View>A ctual Size menu. 

8.9. Actual Size 
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Note: This  opt ion will be disabled if the image is curr entl y v iewed at 100 % . At any 

oth er zoom rat io, View>A ctu al Size will be enabled.  

Choose  the View>A ctua l Size command to set  the act ive image to its Actual Size (e.g. 

100 % ). 

8.10. Track  

Note:  I f the video/ image  size is sm aller than the window size.  The tr ack operat ion  will 

be disabled.  

I f the image's actu al size is larger than the video/ image window, check thi s 

command to posit ion  th e video/ ima ge th at  does not  fit  enti rely wi thin the 

video/ image wi ndow. It s funct ion  is sim ilar to th e scroll bars. I t is an alternat ive to 

using the arrow s on th e scroll bars for  positi oning the video/ ima ge withi n the 

window. 

Checking th e View> Track menu wi ll change th e cursor to   and the butt on  on th e 

toolbar wil l be checked.  

Then  keep down  the mouse but ton  to drag the region of in terest  on the video/ ima ge 

to any locat ion in the video/ ima ge window. 

8.11. Properties 

I f an ima ge file listed  in the Brow se window  is highlighted. Choosing the 

View> Prop ert ies comm and or clicking the selected file in the Brow se window wi th th e 

r ight  mouse but ton  wil l br ing up a Prop erti es dialog as shown below :  

The file Prop ert ies dialog including 4 pages. They are General, Security, Details and 

Previous Versions pages. These Prop erty pages may depend on th e operating system 

and we wi ll not  discuss it  in this help manual. 
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9. Setup 

9.1. Start/ Pause    Pause 

I f the wi ndow is run ning,  one can choose the Setup> Sta rt/ Pause comm and to pause 

th e video and choose  th e Setup> Sta rt/ Pause command again to start  the video. 

9.2. Full Screen ESC 

Choosing  th e Setup>F ul l Screen command wil l display the video window in full 

screen style. Choosing the Setup> Full Screen comm and again will return to th e 

defaul t  video wi ndow. 

Note:  The window  should be in focus to make th e Setup> Ful l Screen or ESC 

command enabled.  

9.3. View Propert ies 

The Setu p> View Prop erty wil l help you to understa nd the came ra statist ical 

prop erties. Choose the Setu p> View Prop erty comm and to invoke th e View 

Prop erty dialog as below:  

 
 

The item s in the dialog are descr ibed in the fo llowing table:  
 

I tem  Descr ipti on  

Device ID Unique I D to ident ify the came ra device. 

Device Name Human readable string to ident ify the name of th e came ra 

device.  
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Stil l Ima ge Capture Whether or  not  the came ra suppo rts St il l Ima ge Captu re. St ill 

I ma ge Capture is used for high resolut ion  came ra to capture 

an ima ge with a diff erent resolut ion  fro m th e video. This 

feature is mainly used to capture high  resolu ti on  ima ge under 

low resolut ion  video to compro m ise th e fram e speed and the 

image resolut ion. 

Display Width The video window width. 

Display Height  The video window height . 

Video Width The actua l video window video width . 

Video Height  The actua l video window video height . 

Compr ession  The compr ession for mat  of the video stream.  

Bits Per Pixel I ndicate how many bits are used to store on pixel. 

Time (second)  Seconds elapsed since the video has been started.  

Fram e Fram es acquired since the video has been started.  

Actual Fram e Rate Actual fram e Rate of the video stream. 

Note:  The Actual Fram e Rate is listed for reference.  I t  varies depending on the 

computer's configurat ion. Different hardware  configurat ions ma y have different 

Actual Fram e Rates. 

9.4. Video Overlay 

9.4.1. Video Overlay: Overlay 

Choose the Setup>V ideo Over lay command  and click the Overlay page to over lay 

Scale, Magnificat ion, Date and Clar it y Factor on the video window. 

 

This command wil l invoke  Over lay page as above.  The Position, Font  Size, Font 

Weight  of the Scale, Magnificat ion  and Date, and Clar it y Factor can be defined 
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togeth er. Their  Color s can be defined separately. 

Clicking th e OK but ton and the Scale, Magnificati on  and Date, and Clar it y Factor will 

be over laid on th e Video window. The Clarity Factor can tell if th e sam ple is in goo d 

focused state.  The larg er the Clar it y Factor, the better  the sam ple focused.  

Note:  To enable the Scale bar, the Magnificat ion  must  be defined and chosen first. 

The Unit  can be any uni t  except  Pixel. There are two me thods to set  the Unit , they are:  

a)  Choosing th e Unit  in the Unit  dropdow n combo box  ( )  

on  th e tool bar which is just  on  the left  of the Magnificati on  dropdow n list  

box;  b) Choosing the Opt ion>M easurem ent comm and, a  dialog cal led 

Measurem ent  will br ing up, click the Length Unit  page and check the Unit  in th e 

Curr ent to set  the Unit. 

9.4.2. Video Overlay: Marker 

Choose  the Video Over lay:  Marker command to overlay Video Marker on the video 

window. The Video Marker type can be Cross, Rectangle, Circle, Cross+ Rectangle, or 

Cross+ Circle. The Video Marker is shown  as below:  

 
 

Choosing  ñCross+ Rectangleò in th e Type combo box  and Video Over lay:  Marker dialog 

wi ll become:  
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Edit  th e Cross Width and Cross Height , Rectangle Width and Rectangle Height , x 

Off set  and y Off set, in their  specific fields.  Click Color to define the Video Marker 

color. 

Click OK to end the Video Marker dialog and a Cross+ Rectangle Marker will be 

over laid on the video window as shown  below :  

 
 

Click  Cancel to cancel the Video>O verlay:  Marker setu p and return to the app licat ion 

area, or App ly to overlay the Marker on the video and keep the Video Overlay dialog 

th ere for further modificat ion. 

9.5. Video Watermark 

Fig.1 shows  a m icro ruler. The dark lines can be extr acted as Video Watermark and 

over laid on the video window. The steps are:  

1.  Choose th e Capture> Capture Ima ge command or click               to capture the 
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micro ruler im age as shown  in Fig.1;  

2.  Choose the Process> Binary  command to binarize the ima ge as shown in Fig.2;  

3.  Choose the I mage>Ad just> I nvert  command to inv ert  the image and choose 

the I ma ge> Color Quantize command to convert  the image to 24 bits as in 

Fig.3. C hoose the File> Save As command to save the image in 24 bit  BMP 

for mat ;  
 

 

 
 

 

 
 

Fig.1 Captur ed Micro Ruler Fig.2 Micro ruler after being binarized 
 

 
 

 

 
 

Fig.3 Inverte d 24 bits image Fig.4 Video Waterma rk set up dialog 

4.  Choosing the Setup> Video Watermark  command and a dialog called Video 

Waterma rk is bro ught  up as shown in Fig.4.  Click the   butt on to locate the 

image saved in step 3.  Use the default s Transparent  (% )(50). I f everything is ok , 

click OK but ton. The final Video Waterma rk is over laid on the video window as 

shown  in Fig.5.  
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Fig.5 Video Window with Video Waterma rk overlaid 
 

9.6. Move Watermark 

9.6.1. Move to 

I f there is Watermark overlaid on  the video window, this me nu wil l be enabled.  

Choosing the Setup> Watermark  comm and wil l br ing up a Move dialog.  

Where o ne can enter the X:  and Y:  off set  value in their  fields for the desired 

pixel move d istances.  The defaul t  X and Y off sets are 0;  

 

 
 

 
 

9.6.2. Move to zero 

I f the Waterm ark was moved,  this menu  will be enabled.  Choosing this menu 

will move the Video Waterma rk to it s or igina l coord inates (0, 0) . 

9.7. Rotate Watermark 

9.7.1. Rotate to 

I f there is Watermark overlaid on  the video , this menu wi ll be enabled.  

Choosing the Setup> Rotate Watermark> Rotate to command will br ing up 

a Rotate dialog,  where one can define an angle to Rotate the Video 

Watermark a specified angle around the video center (0, 0)  (defaul t  value) . 
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9.7.2. Rotate to zero 

I f the Video Watermark was rotated , the Rotate to zero menu wil l be 

enabled. C hoos ing this menu will ro ta te th e Video Waterma rk to zero degr ee.  

9.8. Gray Calibration 

This funct ion  can ma ke the image  br ightness a desired value among 

var ious scenarios in a specified area,  achieving the conti nui ty requirem ent  of th e 

observati on. The Gray Calibrat ion steps are summarized as follows:  

1.  Click the Expo sure & Gain gro up name  on the Came ra Sidebar to exp and the 

Expo sure & Gain gro up, uncheck the Aut o Expo sure box (I f it  is checked) . 

 

2.  Choose the  Edit> Ima ge Select  command or click th e I ma ge Select  butt on    on 

th e toolbar to select a reference region, and choose the Setup> Gray Calibrati on 

command.  A dialog called Gray Calibrati on  will be bro ught  up to display the 

curr ent ROI Average Gray. Now the br ight ness of the microscope can be adjusted 

unt il th e Average Gray reaches the desired value.  Click ñOKò to finish the 

cal ibrat ion and retu rn  to the applicat ion area.  The desired value here is around 

200.  

9.9. Video Source Property 
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This menu wil l be displayed and enabled  only when the came ra that 

suppor ts D irectShow interface is started. 

Choose th e Setup> Video Source Prop erty command  to invoke the Video 

Source Prop erty dialog:  

The Video Source Prop erty includes several  categor ies such as Color , 

Expo sure, Extended, Misc and ROI  page et  al. These pages are  used for the 

cont rol  of your c ame ra. 

 

Note:  Different  came ra may have different  contro l cont ent s. I f you have 

any pro blem s wit h th ese contro ls,  t ry to cont act  your came ra supplier to get  

th e further technique help. ALTRAview  is not  responsible to help you about  these 

cont rols. 

9.10. Video Stream Format 

This menu wil l be displayed and enabled  only when the came ra that 

suppor ts D irectShow interface is started. 

The ALTRAview  Video Stream Form at  configur at ion dialog is shown below:  



Help  Ma nu al   

 
Page 68 of 176 

 

 
 

One can change the video format  mode,  fram e rate,  color space,  

compr ession opti ons and so on. Here,  we only have th e Video Size to check. 

Selecti ng the desired o ne and clicking OK. This wi ll give you a selected 

Video Size for  the new video w indow. 

Click Cancel to cancel the  select ion  and return to video wi ndow without  any 

changes or Apply to app ly the curr ent select ion to the video wi th the 

Prop ert ies remain opened.  

Note:  Diff erent devices may have different  user in terf aces and items. Contact  

the came ra supplier for detai ls.  

9.11. Still Image Options 

Some came ras can capture a stil l ima ge with it s sizes diff erent fro m the video 

stream . The came ra may have a ñpinò th at  acts as a hardw are tr igger, or it  

may suppor t software tr iggering.  A came ra that  suppo rts stil l images capture 

will expo se a stil l image pin to the designer. 

To capture a still  im age, one should first  set  the size of th e image to captu re.  The 

size is determined by the came ra hardw are.  Here we show an exam ple 

with UCMOS08000 KPA came ra. 

Choosing  th e Setup>S til l I mage Opt ions comm and will show th e 

followi ng 

Prop ert ies dialog:  
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I t  has 3264*2448 , 1600 * 1200 , and 800*60 0 resolut ions.  Select  the desired one 

and press OK to accept  the selection,  or Cancel to ignore the curr ent  

selecti on. Click Apply to app ly the selecti on. 

 
 

One can find if the device suppo rts St il l Ima ge Captu re  or not  by choosing 

th e Setup>V iew Prop erty command.  

I f the  Stil l I ma ge Capture 's Value is Y in the View Prop erty dialog,  this means that  

the came ra suppo rts the St ill Ima ge Capture operat ion. 



Help  Ma nu al   

 
Page 70 of 176 

 

10. Capture 

10.1. Capture Image             F8 

During th e video preview , you can always choose the Captu re>I mage 

Captu re command to captu re the video ima ge. 

After the image is captured, the captured  ima ge wil l be the curr ent  active 

window. The Capture>C apture Ima ge menu wil l be disabled.  I f you wish to 

captu re ima ge again, click th e video window ti t le to activ ate the video window 

and the Capture>C apture I ma ge m enu will be enabled again. 

Note:  a)  The ñSnapò button    on the Came ra Sidebar can continuously 

shoot th e image even if the video wi ndow is not  act ivated. Click th is but ton  on the 

Came ra Sidebar to captu re  image quickly ; b) Only when the video window is 

act ive,  th e Capture>C apture Ima ge me nu wil l be enabled;  c)  I f the Live and 

Snap resolut ions are  different , ALTRAview  needs to switch the resolu ti on  fro m 

Live to Snap in th e backgro und to capture an image wi th Snap resolut ion. 

After th e Snap is f inished, ALTRAview  wil l switch back to the Live resolu ti on  to 

conti nue the video s tream pro cess.  Thus it  wi ll take more t ime to capture a sti ll 

image. 

10.2. Time-lapse (Auto Capture) 

This funct ion can captu re a sequence of pictures  wit h the same time in terval;  you 

can pr ecisely set  the t ime in terval (2 to 360 0 seconds)  and the total number of 

images. C hoosing the ñCaptu re> Time- lapse (Auto Capture)ò command wil l 

br ing up Time - lapse (Auto Captu re)  dialog shown below:  

Directory :  The file Directory can be select  by clicking  the Brow se button . 

File:  The File name including Name of Format, File Prefix, File typ e. I t  can be 

a combinat ion of prefix, t ime and typ e and is shown in the Sam ple. 

Time Slot :  Time slot (Second,2-3600S ) is a time segment  to capture an im age. 

Total I ma ges:  Checking  Total Ima ges will enable its edit  box.  You can enter the 

Total Ima ges (1-9999 )  to be captu red.  ALTRAview  will stop the Time-lapse capture 

pro cess automat ically when the Total Images are reached.  

I f Total Images is unchecked,  ALTRAview  wil l capture the ima ges continuously 
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unt il you  choose the Capture>S top Time-lapse (Auto capture) command again to 

stop th e Time - lapse capture.  

 

Click OK to begin  the Time- lapse capture, or Cancel to cancel the Sta rt 

Time -Lapse(Auto Captu re) command.  

After the Time - lapse capture  is started,  th e Capture>S tart  Time-Lapse 

(Auto Capture) me nu wi ll be changed to the Captu re> Stop Time- lapse (Auto 

capture) menu. Choosing this comm and will stop the Time-lapse capture. 

There are a variety of ima ge for mat  avai lable (t hey are bmp, jpg, png and t if)  to 

save th e captured ima ge. For exam ple,  when choosing jpg for mat, you can  

set  th e param eters of ñOptionò to adjust  its compression  qual it y or encoding 

method. Please c heck the File> Save As me nu for detai ls.  

10.3. Start  Record F9 

You can a)  choose  the Captu re> Start  Record  comm and;  b)  click ñRecordò 

but ton    on the Came ra Sidebar ;  c)  use the shor tcut  key ñF9ò to 

start recording mov ies.  The video format  can be wmv/ asf (recomm ended)  or  

avi;  
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1.  Clicking Next  on th e Video Format  dialog wil l br ing up Video File dialog as below; 

Enter the video file nam e under 1.Set  the nam e for the captured video file f ield and 

click the Brow seé but ton  under 2 Select  the director y for  the video file it em  to locate 

th e video file director y. Click Back to return  to the Video Forma t  dialog, or Next  to the 

next step;  

 
 

2.  An Encoder dialog  wil l be brought  up. Here you can select  the Encoder for ma t , set 

th e Bitr ate (Kbps) (256-16384 ), Qual it y (1-100 )  and Key Frame s Spacing (1-30 ) . Click 

Back to return to the Video Format  dialog,  or Next  to the next  step;  
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3.  A dialog called Display I nformati on  will  be bro ught up. Here you c an enter Titl e, 

Aut hor , Copyr ight  and Descr iption to their  f ields. Click Back to return to the Encoder 

dialog,  or Next  to the next  step;  

 

4.  A dialog called Sta rt  to Capture will  be bro ught  up. Here you can check Time Limit 

(Minutes 1-1440 ) and e nter recording t ime  (I f checked) ;  I nput Time- lapse(1-100 ) . 

There is a Sum m ary text  to display what  you  have defined.  Click Back to return to the 

Encoder dialog, or Finish to end the setup;  
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5.  After  the Video capture is started.  The                         butt on  on the Came ra 

Sidebar  will   become   .  Clicking    wi ll stop th e 

capture pro cess, otherwise ,i t  wil l stop unt il th e Time Lim it  is reached. After th e 

Video captu re pro cess is f in ished . The   on the Came ra Sidebar 

will become    fo r th e futu re Record pro cess;  

6.  You can choose  the File>Op en Video command to display the captured video f ile 

in the video window;  

7.  Clicking on  th e video window with your r ight mouse but ton  will br ing up a context 

menu. I t  includes the View Prop erties menu to check the Video Prop ert ies, th e 

Sta rt/ Pause me nu to start  or pause the video and the Full Screen menu to display the 

video in full screen mode. These commands can also be performe d by choosing th e 

Setup>S tart/ Pause, Setup> View Prop ert ies or Setup>F ull Screen menu. 

 

10.4. Start Broadcast 

Sta rt  a networ k bro adcasti ng service.  Select  the port  and the video for mat  befor e 

start  th e service.  After that , ALTRAview  wil l start  bro adcast ing the video tha t  is opened 

by ALTRAview  locally via the specified por t  and for mat . The oth er users could share the 

video by open bro adcasting functi on. 
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Clicking the Next>  button  to set  the video Encoder parameters for br oadcasti ng. This 

set  up dialog is just  the sam e as th ose of video record pro cess set  up dialog.  I t  mainly 

including Encoder, Encode Parameter such as Bitrate, Qualit y, Key Frame  Spacing in 

second et  al. 

 
 

Clicking  th e Next>  but ton again wil l invoke the Start  to Broadcast  dialog.  Here,  one 

can set  the br oadcast  Time Limit  in m inutes.  The Encoder parame ters are also listed 

in the Summa ry wi ndow for reference.  

Clicking  th e Finish but ton wi ll s tart  th e br oadcasti ng pro cess and it  wi ll end the 

pro cess when it  reaches to the Time  Lim it. 
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See File>Op en Broadcast  to understand the Sta rt  Broadcast  funct ion. 
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11. Image 

11.1. Mode 

11.1.1. Color Quantize 

The Color Quanti ze command  is widely used to change th e image bit. ALTRAview  

suppor ts the m utual changes among 24 bit , 8 bit , 4b it  or 1 bit  images. 

When th e Color Bits dialog is opened, th e default checked 

color bit  is the  curr ent image's color bit . Check th e desired 

bit  and click OK to end th e command. The image will 

converted to th e selected color bit s in th e image window. 

11.1.2. Gray Scale 

Choose th e Gray Scale command to conv ert  a color ima ge ( true color ima ge or index 

color image)  to a gray scale ima ge. I f th e or iginal image is 24 bit , the new image is 8  

bit . Otherwise the bit  of the image will not be modified.  

11.2. Adjust 

11.2.1. Curve 

Choose th e I ma ge>Ad just> Curve command to adjust  the enti re tonal range of an 

image. But  instead of making adjustments using only th ree var iables (h ighl ight, 

shadow, m idtone) , one can adjust  any poin t  on the curve along a 0-25 5 scale while 

keeping up to any other values constant . One can also use Curve to make precise 

adj ustment s fo r individual color channels on an image.  The Curve dialog is shown 

below:  
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Horizontal 
Axis 

The horizont al axis of th e graph represent s th e original int ensity values 

of th e pixels (I nput  levels). 

Verti cal 

Axis 

The vertical  axis represent s the new color values (Out put  levels). I n 

th e default  diagonal lin e, all the pixels have identi cal I nput  and 

Out put  values. 

Curve 

area 

Area (specified with the blue rectangle)  to setup a m ap between 

input and out put;  

a)  When  you open th e Curve dialog you see, perhaps surprisingly, 

not  a curve but a  straight  lin e. As a default , th e input  values are 

the sam e as th e output , so th ereôs no chan ge;  

b)  By clicking  in th e cent er of th e lin e and dragging upwards, we 

ma ke our first  curve. Raising th e curv e increases th e overall 

brightness of th e scene. 

c)  Conversely , clicking in th e cent er and dragging downwards lowers 

th e br ightn ess, producing an im age tha tôs darker overall;  

d)  As well  as clicking in th e cent er, we can also adjust  th e 

endpoint s. Clicking th e top right  point  and dragging down lim it s th e 

brightest  part  of th e ima ge, reducing contrast.  

e)  I f we drag th at  top right  point  to th e left  rath er th an down, we 

produce th e opposite effectðincreasing th e contrast  of th e image. 

This is a very useful and contr ollable quick fix;  

f)  By dragging the top and bottom point s towards th e cent er, we 

create a stylized, posterized  effect th at  tu rns any photo graph 

int o more of a graphic object. 

g)  Click once in th e center of the RGB curve to "pin"  th at  m idpoint ;  

now drag just  th e to p half of the curv e to ma ke thi s S shape, and 

the result  is to increase th e overall contrast. 

h)  You can add up to any control  po in ts to the curve,  locking 

th ose values. To remove a contro l po int , 1)drag it  of f the graph  

or 2)click the r ight  mouse but ton on th at point.  You cannot  delete 

the endpoints of the curve.  



Help  Ma nu al   

 
Page 79 of 176 

 

 

 
a) 

 
b) 

 
c) 

 
d) 

 
e) 

 
f) 

 
g) 

 
h) 

Grid Check to overlay the gr id on the Curve window;  

Channel 

 
 
 
 

To adjust th e color balance of th e ima ge, check th e channel(R, G or B) 

from  the Channel butt on. Check th e whit e but ton to select  RGB channels 

at  th e same time, which is located on th e left  of th e R (Red), G (Green)  

and B (Blue)  butt ons;  

Curve Click the Curve wit h your left  mouse but ton, a spline curv e (str aight  line) 

wi ll s etup the in iti al input-output relat ion. C lick on the Curve wi ll ma rk 

th e Curve with a poin t. The point  number can be any as long as it  can be 

inserted on the Curve. Drag th e marked point  unti l th e ima ge looks 

sati sfactory. The point  can be deleted by move the mouse on it  and click 

th e right  mouse butt on  on it . 

Pencil   Check th e pencil butt on at  th e bott om of the dialog, and use your left  

mouse but ton  to draw a new arb itrary Curve in the Curve area. 

Reset Click the Reset butt on  wil l reset  the Curve to the init ial str aight  line. 

Apply Apply curr ent  Curv e ma p on the image. 

11.2.2. Auto Level 

The I ma ge>Ad justment>A uto Level comm and moves the level's  sliders 

automat ically to set  highl ight  and shadow. I t  defines the lightest  and dark est  pixels 

in each color channel as white and black and then redistr ibutes the pixels' color 
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values propor t ionately. Since Auto Level adjusts each color channel individually, it 

may rem ove or introd uce color casts.  The Aut o Level command moves the level's 

sliders automat ical ly to set  highl ight  and shadow. I t  defines the lightest  and darkest 

pixels in each color channel as white and black and then redistr ibutes the pixels' color 

values propor t ionately. Since Auto Level adjusts each color channel individually, it 

may rem ove or introduce color casts. 

By default , this feature clips the white and black pixels by 0.5% -- that is, it ignores 

0.5%  of the light est  pixels and 0.5%  of the darkest  pixels when ident ify ing th e 

lightest  and darkest  pixels on  th e im age.  Choose the Opt ions> Auto Corr ection 

command to modify this default  setti ng. This ensures th at  white and black values are 

repr esentat ive wi th out  being determ ined by extrem e pixel values.  The Auto> 

Corr ect ion dialog is shown below:  

 
 

The I ma ge>A djustment>A uto Level command gives goo d results when an ima ge 

with an average distr ibut ion of pixel values  needs a simple cont rast  adjustment  or 

when an image has an overall color cast . However, adjust ing th e Curves manually is 

more precise. 

See I mage>Ad justment>A uto Cont rast  fo r anoth er auto adjust  command. 

11.2.3. Auto Contrast 

The I ma ge>A djustment>A uto Cont rast command  automat ically adjusts the overall 

cont rast  and mixture of color s in an RGB ima ge.  Since it  does not  adjust  channels 

individua lly, Auto Contr ast  does not  int roduce or rem ove color casts.  I t  ma ps th e 

lightest  and darkest  pixels in the im age to white and black,  which makes highl ights 

appear lighter and shadow s appear darker. 

When ident ify ing the lightest  and darkest  pixels on  an image,  Auto Contr ast  clips th e 

white and black pixels by 0.5% --th at  is,  it  ignores the first  0.5%  of either extrem e. 

Choose the Opt ions> Auto Corr ect ion menu  to modify this defau lt  set ting.  This 

ensures that  whi te and black values are repr esentat ive without  being determ ined by 

extrem e pixel values. The Auto Corr ection dialog is shown below:  
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The Auto Contr ast  command  can impro ve the appearance of many photographic or 

conti nuous-tone images. I t  does not  impro ve flat-color images. 

See I mage>Ad justment>A uto Level for another  auto operati on. 

11.2.4. Histogram Equalization 

Histogram Equalizat ion  is a kind of histogram process . The histogram can reflect  th e 

stat ist ical infor mat ion for the R, G, and B of the pixels of the or iginal im age.  The 

algor ith m  calculates each separately, equa lizes the R, G, and B of the poin ts linear ly, 

and reassigns them 

11.2.5. Brightness/Contrast 

The Ima ge>A djustme nt> Brightness/ Contra st command  off ers simple 

adj ustment s to the tonal range of an image.  This command makes the sam e 

adj ustment  to every pixel in the im age.  The Br ight ness/ Contr ast  command does not 

wor k wit h individual channels and is not  recommended for high-end output  because 

it  can resul t  in the loss of details about the ima ge. 

 

Preview:  Check this  button  to display real- t ime effects when drags th e slider bar. 

Defau lt  is checked 

Br ight ness:  Dragging  the slider bar to th e left  decreases the level and dragging it  to 

th e right  increases the level. The numbers on  the right  of the slider bar displays the 

Br ight ness value.  Values can range fro m -100 to +100 . Defaul t  is 0;  

Cont rast :  Dragg ing the  slider bar to th e left  decreases the level and dragging it  to the 

r ight  increases the level. The nu mbers on the right  of the slider bar displays the 

Cont rast  value.  Values can range fro m -100 to +100 . Default  is 0;  
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11.2.6. Color 

Choose the I ma ge>Ad justment> Color  command  to modify the overal l m ixtu re of th e 

color s in an ima ge.  

There are four color  modules:  

RGB 

ALTRAview  uses the RGB model. I t  assigns an int ensity value to each pixel 

ranging from 0 (black) to 255 (whit e)  for each of th e RGB component s in a 

color ima ge. 

For example, a bright  red color m ight  have an R value of 246 , a G value of 20, 

and a B value of 50. When th e values of all th ree component s are equal, th e 

result  is a shade of neutral gray. When th e value of all component s is 255 , th e 

result  is pure whit e;  when th e value is 0, pure black. 

RGB ima ges use thr ee channels to reproduce up to 16.7 m illi on colors 

on-screen. I n add iti on to being th e default  mode for new ALTRAview  ima ges, th e 

RGB mode is used by computer monit ors to display colors. This mea ns th at 

when working in color modes oth er th an RGB, such as CMYK, ALTRAview  uses 

RGB mode for display on-screen. 

Alth ough RGB is a standard color mode, th e exact range of colors represent ed 

can vary, depending on the applicati on or display device. 

 
 
 
 
 
 
 
 
 
 
 
 
 
  

CMYK 

The CMYK mode is based on th e light -absorb ing qualit y of ink print ed on 

papers. As whit e light  str ikes translucent  inks, certain visible wavelength s are 

absorbed whil e oth ers are reflected back to th e eyes. 

I n th eory, pure cyan (C), magent a (M), and yellow (Y)  pigment s should 

combine to absorb all light  and produce black. For thi s reason th ese colors are 

called subtracti ve colors. Because all pr intin g inks cont ain some impuriti es, 

th ese three ink s actu ally produce a muddy brown and must  be combined with 

black (K) ink to produce a true black. (K is used instead of B to avoid confusion 

with blue.)  Combinin g th ese inks to reproduce color is called four -color process 

pr intin g. 

The subtracti ve (CMY) and additiv e (RGB) colors are compleme nt ary colors. 
Each pair of subtracti ve colors creates an add itiv e color, and vice versa. 



Help  Ma nu al   

 
Page 83 of 176 

 

 

HSI  

Based on th e huma n perception of color, th e HSI  model describes thr ee 

fundament al characteristi cs of colors:  

Hue is th e color reflected from or transm itt ed thr ough an object. I t  is me asur ed 

as a locati on on th e standard color wheel, expressed as a degree between 0° 

and 360 ° . I n common use, Hue is identi fied by th e name of the color such as 

red, orange, or green. 

Satur at ion, some times called chr oma , is th e strength or purit y of th e color. 

Satur at ion represent s th e amoun t  of gray in propor ti on to the hue, me asur ed 

as a percent age from 0%  (gray)  to 100%  (ful ly satur ated). On th e standard 

color wheel, Sat ur ati on  increases from th e cent er to th e edge. 

In tensit y is th e relati ve lightn ess or dark ness of th e color, usually measured as 

a percent age from 0%  (black)  to 100 %  (whit e).  

HLS 

The HLS model is very sim ilar  to th e HLS color model. The ma in dif ference 

between th em is th e calculatio n used to produce th e brightn ess value. I n th e 

HLS model, a pixel's brightn ess (L) is derived fr om it s three (R, G and B) color 

values. I n the HLS model, a pixel's brightn ess (L)  is determined by the 

mini mum and maximum values of it s th ree color values. 

 

Preview:  Check this  but ton  to display the real- t ime effect  when the slider 

bar's position  is modified.  

The values beside  the slider bar show the color changes in var ious color channels. 

For RGB channel values,  they can range fro m -100 to +100 . Defau lt  is 0;  

For CMYK channel  values, they can range fro m -10 0 to +100 . Defau lt  is 0;  

For HSI  channel  values, the H value can range fro m -180 to 180, th e S value 

can range fro m -275 to 275 , and the I  value can range fro m -44 2 to 442 .Defaul t  

is 0;  
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For HLS channel values,  the H value can range fro m -180 to 180, the L value 

can range fro m  -100 to 100 , and the S value can range fro m -10 0 to 100 . Defaul t  

is 0;  

11.2.7. HMS 

Choose the I ma ge>Ad justment> HMS comm and to adjust  the HL (Highlight ), M 

(Midtone) , and S(Shadow)  parts of the ima ge.  Each part's value ranges fro m -10 0 

to 100 . This comm and is only avai lable for  24 bits true color ima ge. 

Preview:  Check this butt on  to display the real- t ime effect  when one changes 

th e sl ider bar's posit ion. Defau lt  is checked. 

 
 

11.2.8. Gamma 

The Ima ge>A djustme nt> Gamma measures the brightness  of m idtone values 

prod uced by a device (of ten a moni tor ) . A higher gam ma  value yields an 

overall darker ima ge.  

 
 

Preview:  Check this  but ton to display the real- t ime eff ects when one changes 

th e slider barôs position. Default  is checked;  

Gam ma:  Dragging  the slider bar to the left  decreases the level, while mov ing it  to 

th e r ight  increases the level.  Values can range fro m 0 to 3.0. Defaul t  is 1.0. 

11.2.9. Filter Color 

Choose th e I mage>Ad justme nt> Filter  Color command to filter  a special 

color c hannel fro m  a color ima ge. Check eit her Red, or Green, or Blue color to 

filt er. For every pixel, if check Red color to filter, only infor mati on  about th e red 

channel wil l be discarded , and Green and Blue infor m ati on  wil l remain there. 
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See Extract  Color for  anoth er color operati on. 

11.2.10. Extract Color 

Choose  the I m age>Ad justment> Extra ct  Color  comm and to extr act  a special color 

channel fro m  a color image.  Check either Red or Green, or Blue color to extract . 

For every pixel,  if selecting Red color to extr act , only infor mati on  about  th e 

red c hannel wil l be kept, and Green and Blue infor mat ion will be discarded. 

 
 

See Filter Color  fo r another  color operat ion. 

11.2.11. Invert 

Choose th e Ima ge>A djustment> I nv ert  command  to reverse th e pixel values of 

the act ive ima ge wi th out  going through the lookup table. 

11.3. Rotate 

Choose the I mage> Rota te command  to rotate th e ent ire ima ge. One has 

th e followi ng subme nus:  

11.3.1. 90(CW) 

Rotate the ima ge clockwise  by a quarter - turn. 

11.3.2. 180(CW) 

Rotate the ima ge clockwise  by 180 degr ees. 

11.3.3. 270(CW) 

Rotate the ima ge clockwise  by 270 degr ees. 
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11.3.4. Arbitrary 

Rotate the ima ge by a specified angle.  I f choosing this opti on, enter an angle 

between 0  and 360 degr ees in the angle text box, and check CW or CCW to ro tate 

clockwise or counterclockwise.  For the Arb itra ry  operati on, it  will inv oke an I ma ge 

Rotate dialog like below :  

 
 

Degr ee:  The degree  that  th e image to be ro tated.  

CW:  Rotates  the ima ge clockw ise.  

CCW:  Rotates  the  image  count erclockwise.  

Qualit y:  One can select  one of the th ree methods fo r the image rotat ion among 

Nearest  Neighbor , Bilinear, and Bicubic. The default  is Bilinear. 

11.3.5. Flip Horizontal 

Reverses the ima ge in th e application  area so that the top right  corner of the or iginal 

image is now the top left , and the top left  corner of the or iginal ima ge is now the top 

r ight  corner. 

11.3.6. Flip Vertical 

Reverses the ima ge in th e application  area so that the top right  corner of the or iginal 

image is now the bott om  r ight corner, and th e top left  corner of the or iginal ima ge is 

now the bott om  left  corner. 

11.4. Crop  Shift+C 

Choose th e I m age>Cro p command to remove  the por t ions of an image th at  does not 

want  so that  the focus is on the part  of the image th at  is left. This docume nt instructs 

users on  how to Crop an image in ALTRAview . 

11.4.1. Crop Demo 
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1.  Choose the Open I mage command  to open an ima ge to Crop ;  

2.  Choose the Edit>  I ma ge Select  command  or click the I mage Select  but ton    

on th e Toolbar, the cursor wil l change to a small cross. 

3.  Move the cursor over  the ima ge to th e desired locat ion, click the mouse but ton  and 

hold it  dow n to ma rk the first  position. 

4.  Drag th e mouse  over the part  of th e image to be kept, a dott ed rectangle appears 

around the select ion and release the left  mouse butt on. 

5.  Opt ion 1:  To move  the rectangle:  a)  Move the mouse over the selected area and 

when it  becomes a move cursor, click and hold the left  mouse but ton;  b)  Drag th e 

selected area to the desired position. 

 
 

6.  Opt ion 2:  To change  the size of th e recta ngle:  a)  Put  the mouse cursor on one of 

th e handles tha t appear on  the edges of the selected area;  b)  Click and hold th e 

mouse but ton;  c)  Drag the box to the desired size.  

 

Note:  Each of the handles  th at  appear on the edges of the box sizes th e box 

diff erent ly. 

7.  To Crop the image , choose the I ma ge>Cro p command or pr ess Shift+ C butt ons.  

Note:  I f th e selected  area is on the video, choosing th e I ma ge>Cro p command wil l 

capture the selected area and display it  on a new image window. 

11.5. Image Scale 

Choose th e I m age> Ima ge Scale command  to change the image to a specified 

size.  This pro cess actu ally changes spat ial resolut ion  by adding (replicati ng)  or 

rem ov ing (decimati ng)  pixels to achieve the specified dimensions.  

Width and Height :  When choosing  the I ma ge Scale command;  the dialog displays 

th e dimensions of th e or iginal image  in pixels. The Width and the Height  can be set 
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on the new image by add ing or rem ov ing pixels.  I f Constr ain Propor t ions is checked, 

th e Width and Height  wi ll stay propor t ionate to each other. I f Constrain Propo rti ons is 

unchecked,  the Width and the Height  can set  independent ly, but  th is will distor t  th e 

image. 

 
 

Reset :  Reset  the ima ge Width and Height to the or iginal ones. 

Constrain Propor t ions:  To maintai n the curr ent  propor t ions of pixel Width and Height, 

check Constr ain Propor t ions. This opt ion automatical ly updates the Width as th e 

Height  is modified, and vice versa. Otherwise , uncheck the Constrain Propor t ions 

but ton. 

Scale method:  There are  3 opt ions for the Scale method. They are:  Nearest  

Neighbor , Bilinear, and Bicubic. The defaul t  is Bilinear. 

11.6. Histogram 

A Histogram il lustrates how  pixels in an ima ge are distr ibuted by graphing the 

nu mber of pixels at  each color intensit y level.  The Histogram shows wheth er the 

image conta ins enough  detail in the Shadow s (shown  in the left  part  of th e 

Histogram), Midtones (shown in the middle) , and Highlights (shown in th e r ight  part) 

in ord er to make a goo d corr ect ion. 

The Histogram  also gives a quick  picture of th e tona l range of the ima ge,  or the 

image key typ e.  A low-key ima ge has detai l concentr ated in th e shadow s, a high-key 

image has detai l concent rated in the highlights,  and an average-key ima ge has detail 

concent rated in the Midtones. An im age wi th a full tonal range has a number of pixels 

in al l areas.  I dent ify ing the tona l range helps determ ine th e approp r iate tonal 

corr ect ions.  

Choose the Ima ge> Histogram comm and to open  the Histogram dialog as shown 

below. 

Depending on the im ageôs color mode, c hoose R, G  and B, or Lum inosit y to view a 

composite Histogram of all the channels. 
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I f the image  is RGB true color, choose Lum inosity to display a Histogram repr esenting 

th e lum inance or in tensity values of th e composite channel.  

 

  

  

I f the ima ge is RGB true color, choose R, G and B to display a composite Histogram of 

th e individual  color channels in color. 

Do one of th e follow ing:  

1.  To view infor mati on  about  a specific pixel value,  place the mouse pointer in the 

Histogram. 

2.  To view infor mat ion about  a range of values, click dow n the left mouse butt on  

and drag it  in the Histogram to highl ight  the range.  

The dialog displays the following sta tist ical infor mat ion below th e Histogram: 

Pixels:  Repr esents the total number of pixels used to calculate the Histogram. 

Level:  Displays the in tensity level of th e area underneath the pointer. 

Count :  Shows the total number  of pixels corr esponding to the in tensity level 

underneath th e pointer. 

Percent ile:  Displays  the cumulat ive number of pixels at  or below the level 

underneath the pointer. This value is expr essed as a percentage of all th e pixels in 
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th e image,  fro m 0%  at  the far left  to 100 %  at  the far r ight . 

11.7. Resolution 

Choose  the Ima ge> Resolu ti on comm and to set  the im age Resolut ion to calibr ate th e 

spatial scale.  By defaul t, ALTRAview  expr esses spat ial me asureme nts in terms of 

pixels.  This Resolut ion  command is used to change the terms in which ALTRAview  

reports such measurement s.  This comm and should be run first  in ord er to mea sure 

objects in terms of un its other th an pixels. 

 

X:  Horizontal  PPM (Pixels per meter)  of curr ent  Resolut ion. Y:  Vertical PPM (Pixels 

per meter)  of curr ent  Resolut ion. 

Note:  The resolut ion  in th e Y direct ion need not  to be f illed.  ALTRAview  wil l always let 

it  equal to th e X direct ion. 

After the new Resolut ion is set , all of the measurem ents wil l be calculated according 

to the new Resolu ti on. (See more in the Measurem ents and 

Opti ons> Measureme nt me nu).  
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12. Process 

12.1. Filter Shift+F 

Choose the Process>F il ter command  to apply one of ALTRAview 's nume rous filt er  on 

th e act ive image.  I f you are not  fam iliar  with the pro cess and effects of fil tering, 

some  discussions about  spat ial f ilter ing should be reviewed. ALTRAview  prov ides an 

extensive set of conv olut ion and no convolut ion  (morp hological)  f ilt ers.  you can also 

create custom filter kern els and apply th em  wit h the Filter  commands. 

Choosing the Process>F il ter  command  will open th e Fil ter dialog.  Each gro up of 

f ilters has its own  prop erty page or tab, where the Fil ter typ e and size can be selected. 

The filt ered resul ts are almost  always written to the act ive image.  The Edit> Undo 

command can be used to rem ove Fil ter operat ions that  have been applied.  

12.1.1. Image Enhance 

 

 
 

Low Pass Check thi s filt er  to soften an ima ge by elim inatin g high-frequency 

informa ti on (thi s has th e effect  of blur ring sharp edges). The Low Pass 

filt er  replaces th e cent er pixel with th e mea n value in it s neighborhood. 

The Low Pass filt er  can also be used to remove noise. 

High  Pass Check thi s filt er  to enhance high-frequency inf orma ti on. The High  Pass 

filt er  replaces th e center pixel with a convolved value th at  significant ly 

increases it s contr ast fr om it s neighbors. The High Pass filt er leaves only 

eleme nt s of high contr ast.  
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Gauss Check  thi s  filt er  to  soften  an  ima ge  by  elim inatin g  high-frequency 

informa ti on using a Gauss functi on. This has th e effect of blurr ing sharp 

edges. The operati on of th e Gauss filt er  is sim ilar  to th e Low Pass filt er, but  

it degrades the image less than the Low Pass filter . 

 
High 

Gauss 

Check thi s filt er  to enhance fine details. This operati on is sim ilar to the 

unsharp ma sking techni que (see th e Sharpen filt er), but  it  intr oduces less 

noise into th e image. I t  uses a Gaussian curve type of kernel. Available in 

7x7 and 9x9 kernel sizes. 

Equaliza- 

t ion  

This filt er  is used to enhance the contrast based on the histogram of the 

local neighborhood (See Opt ion below). 

Sharpness Check thi s filt er  to enhance fin e details, or  refocus an image th at  is 

blur red. The sharpen filt er  sharpens th e image using th e unsharp ma sking 

techni que. 

Median Check thi s filt er  to remove impulse noise from an image. The Median filt er 

replaces th e cent er pixel with the Median value in it s neighborh ood. I t  will 

also blur th e ima ge. 

Rank Check thi s filt er  to remove impulse noise fr om an image. The pixels in the 

kernel are rank ed by order of int ensit y, and th e pixel in th at  range at the 

rank percent age is chosen for comparison. For example, in a  5x5 kernel, 

th ere are 25 pixels. A rank percent age of 95%  woul d choose 

second-br ight est  pixel for comparison. I f th e difference between th e 

selected pixel and th e cent er pixel is greater th an th e thr eshold value, th e 

Rank filt er  replaces th e value of the cent er pixel with th e value of the 

selected pixel. 

12.1.1.1 Option 

1.  I f one of the Enhanceme nt  filt ers is checked , the fo llowing opti ons will be 

displayed:  

 

3 x 3 Check 3 x 3 kernel will produce a more subtl e filt ering effect. 

5 x 5 Check 5 x 5 kernel will produce a moderate filt ering effect. 

7 x 7 Check 7 x 7 kernel will produce a more extreme filt ering effect. 
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Passes Set  th e filt er  applied times on the image. When a filt er  is applied multi ple 

times , it s effect is amplified by each pass. An ima ge th at  has been 

softened by one pass of th e Low Pass filt er  will be softened furth er by a 

second pass. 

Strength Enter an applied value from 1-10 th at  reflects how much of th e filt ering  

 effect on th e image. 

A value of 10 specifies th e ful l strength (100% ) of the filtered result 

app lied to each pixel. Values less th an 10 cut  th e ful l weight  of th e filt er. 

A value of 1 indicates th at  only 10%  of th e dif ference between th e filt ered 

pixel value and th e original pixel value should be applied, a value of 2 

indicates th at  20%  of th e dif ference should be app lied, and so forth . 

Rank This value specifies which pixel in th e sorted arr ay will be used to replace 

th e cent er pixel. Pixels in th e array will be sorted in ascending order. The 

pixels are indexed from 0 to Kernel Size x Kernel Size-1. I n the pixel index 

0 corresponds to th e lowest  pixel value. 

The Rank will be specified in terms of a percent age of th e indexes (Kernel 

Size x Kernel Size-1). A 50%  Rank means th e middle of th e array. 0%  rank 

mea ns th e lowest index (lowest  gray value), and 100%  rank means the 

highest  index (hi ghest  gray value).  

2.  I f the  Equalizat ion  fil ter is checked, the opt ions wil l relate to th e histogram 

equal izat ion. Local Histogram Equalizat ion modifies th e contrast  of an ima ge based 

on  the pixel values in a small window surro unding each pixel. 

 

Window I mage pixels stati sti cs (m in, max, histo gram , mea n, standard deviati on, 

etc.)  will be calculated on a sma ll Window of th e image. These 

meas urement s are th en used to derive th e local contr ast  for that area of 

th e ima ge. I n shor t, an area of Window x Window around each pixel is all 

th at  is considered when modifying the int ensiti es in th e image. Larger 

Window produces sm ooth er result s, whil e small Window track sma ll 

details more closely. 
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Best Fit  Choose th e Best  Fit  but ton to optim ize th e values for th e parti cular image. 

The result s are achieved by str etchin g th e local histogram to maximize th e 

contrast  between th e bright est  and darkest pixels in th e local window 

region. 

Linear This opti on distr ibut es th e histogram lin early across th e int ensit y scale. 

This functi on produces a high cont rast  ima ge with th e highest  possible 

dy nam ic range. 

Loga-

r ithmic  

This opti on concentr ates th e histogram at th e low end of th e scale. This 

functi on produces a high contrast  ima ge with littl e dynam ic ima ge. I t  will 

tend to darken the ima ge overall. I t  is useful for increasing th e contrast  in 

a very light  ima ge.  

Expo nen- 

ti al 

This opti on concentr ates the histogram at th e high end of th e scale. This 

functi on produces a high contrast  ima ge with littl e dynam ic ima ge. I t  will 

tend to light en th e image overall. I t  is useful for increasing th e contr ast  in 

a very dark ima ge. 

12.1.2. Edge Enhance 

 
 

Sobel Check thi s filt er  to enhance just  th e principal edges in an ima ge. The 

Sobel applies a ma th ema ti cal formula to a 3x3 neighborhoo d to locate 

and highl ight  it s edges. 
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Roberts Check thi s filt er  to enhance fine edges in an image. The Roberts filt er is 

not  a convoluti on filt er. I t  applies a ma th ema ti cal formula upon a 4 x 4 

neighborhood  to  produce  its  effect.  The  upper  left  pixel  in  th e 

neighborhood is th e one th at  is replaced. 

Sculpt  Check thi s filt er  to app ly a sculpted effect  on th e image. 

Hor izonta l Check thi s filt er  to detect  and emphasize horizont al edges. 

Verti cal  Check thi s filt er  to detect  and emphasize verti cal edges. 

Options  

1.  I f one of the Edge fil ters has been  checked, the opt ions wil l relate to kernel size and 

filter ing strength. The following opt ions wi ll be displayed:  

3 x 3 Check  3x3 kernels  to produce a more subtl e filt ering effect. 

5 x 5 Check 5x 5 kernels to produce a moderate filt ering effect. 

7 x 7 Check 7x 7 kernels to produce a more extreme filt ering effect. 

Passes Enter th e number of times th at  th e filt er  will be applied to th e ima ge. When 

a filt er  is app lied multi ple times, it s effect  is amplified by each pass. An 

ima ge th at  has been softened by one pass of the I ma ge Enhancement  

Filter , will be sof tened furth er by a second pass. 

Strength Enter a value from 1-10 th at  reflects how much of th e filt ering effect to 

app ly to th e ima ge. A value of 10 specifies th at  th e ful l strength (100% ) of 

th e filt ered result  will be applied to each pixel. Values less th an 10 cut  th e 

ful l weight  of th e filt er  -  a value of 1 indicates th at  only 10%  of th e 

dif ference between th e filt ered pixel value and th e or iginal pixel value 

should be applied, a value of 2 indicates th at  20%  of th e difference should 

be applied, and so forth . 

2.  I f Sobel or Roberts is checked , no opt ions are available. 

12.1.3. Morphological 
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Erod e Check thi s morphological filt er  if one want s to modify th e size of objects in 

th e ima ge. The Erode filt er  erodes th e edges of bright  objec ts and enlarges 

th e edges of dark ones. 

Dilate Check thi s morphological filt er  if one want s to modify th e size of objects in 

th e ima ge. The Dilati on filt er  dilates br ight  objects and erodes dark ones. 

Open Check thi s morp hological filt er  if one want s to modify th e shape of objec ts 

in th e ima ge. Assuming  th e image cont ains bright  objects on a dark field, 

th e Open filt er  will smooth object contour s, separate narrowly connected 

objects, and remove sma ll dark holes.  

Close Check thi s morphological filt er  if one want s to modify th e shape of the 

ob jects in th e image. Assuming th e image cont ains bright  objec ts on a 

dark field;  th e Close filt er  will fill gaps and enlarge protrusions to connect  

ob jects th at  are close togeth er. 

Tophat Check thi s filt er  to detect  and emphasize point s, or  grains, th at  are 

br ight er th an th e background. There are 3 kernel sizes for thi s processing. 

Click th e radio but ton to change the kernel size to th e value th at  most  

closely ma tches the size of th e grains to detect. 

Well  Check thi s filt er  to detect  and emphasize point s, or  grains, th at  are darker 

th an th e background. There are 3 kernel sizes for thi s processing. Click the 

radio butt on to change th e kernel size to th e value th at  most closely 

ma tches th e size of th e grains to detect. 

Gradient Check thi s filt er  to enhance edges in an image. 
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Watershed Check thi s filt er  to separate objects th at  are touching. The Watershed filt er 

erodes objects unti l th ey disappear, then dilates th em again, but  will not 

allow th em to touch. The Watershed filt er  will not  operate upon True Color 

images. I f one want s to separate objec ts in a True Color image, he must 

first  convert  it  to Gray Scale (see Process Fram e:  Ima ge> Gray Scale).  

Thinning Check thi s filt er  to reduce an image to it s skeleton. When choosing th is 

filt er, one must  set the thr eshold th at  determines wheth er a pixel is part  of 

th e subject or part  of th e background (see Options below). The Thinnin g 

filt er  will not  operate upon True Color images. I f one wants to thi n a True 

Color image, he must first  convert  it  to Gray Scale. 

Dista nce The distance filt er  is used to show th e distances of pixels withi n blobs to 

th e out er boundaries of th ose blobs. After  applying th e distance filt er, the 

background will be black (i. e. pixels with value 0). Only th e area withi n th e 

blobs will have non-zero values (will be whit e). The values of each pixel 

withi n th e blob will be a count of th e shortest distance fr om that  pixel to 

th e edge of th e blob. Thus, all pixels along th e blob's border will have a 

value of 1 (since th ey are one pixel away from th e edge of th e blob);  pixels 

th at  are a distance of 2 from the border will have th e value 2, and so on. 

This  creates a distance ma p of th e image. The Distance filter will not 

operate upon True Color images. I f one wants to use th e Distance filt er 

wit h a True Color image, he must  first  convert  it  to Gray Scale.  
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Options  

1.  I f Erod e, Dilate, Open, or Close filters is checked,  th e opti ons wil l relate to th e 

kernel size and shape.  The following opt ions wi ll be pr esented:  

 

2 x 2 Square Check to use th e 2x 2 square kernel configur ations. 

3 x 1 Row Check to use th e 3x 1 row kernel configurati on. 

1 x 3 Column Check to use th e 1x 3 column kernel configur ation. 

3 x 3 Cross Check to use th e 3x 3 cross kernel configur ation. 

5 x 5 Circle Check to use th e 5x 5 circular kern el configur ations. 

7 x 7 Circle  

Check to use th e 7x7 circular kernel configurati ons. This is a 

two-pass filt er, accomplished using a 5 x 5 circle fo llowed by a 3x3 

cross. 

11 x 11 Circle 

Check to use th e 11 x 11 circular kernel configurati ons. This is a 

th ree-pass filt er, accomplished using a 5 x 5 circle followed by 

anoth er 5 x 5 circle, fo llowed by a 3 x 3 cross. 

Passes Set  th e number of times it erate th e filt er.  

Note:  The circular kernels are especially eff ect ive on round objects (cells,  grains and 

so on)  because their circular configur at ion preserves the circular shape of the objec ts 

bet ter than square configur at ions. 

2.  I f th e Tophat , Well, or Gradient filter  is selected , the opt ions wil l relate to kernel 

size and shape. The fo llow ing opti ons wi ll be presented:  

 

3 x 3 Check to use th e 3x 3 square kernel configur ations. 

5 x 5 Check to use th e 5x 5 square kernel configur ations. 

7 x 7 Check to use th e 7x 7 square kernel configur ations. 

3.  I f Watershed, Thinn ing, or Distance filter is checked , the opt ions wi ll relate to th e 

threshold.  The fo llowing opt ion will be presented:  

Threshold Enter a percent age value from 1-100 th at  specifies th e int ensity value 

to binarize th e image. For example, a Threshold of 50%  on a Gray 

Scale im age would set all values Ò127  to 0 (black) and all values 

Ó128 to th e ma ximum value for th at  image class (whit e).  
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12.1.4. Kernel 

The Kernel page al lows you to edit  the kernel files fo r th e morp hological and 

convolut ion f ilters.  

 

 
 

Note:  The HiPass, LowPass, Laplacian and  Unsharp kernel f iles are used by 

the HiPass, LowPass, Laplacian, and Sharp en opt ions listed in the I ma ge 

Enhancem ent Filters page dialog window ( i.e. there is no diff erence between 

selecti ng one of these kernel files and selecti ng its Opti on but ton in the Fil ter 

window - -  the two meth ods ult imately do th e same thing) . Because these 

kernel files are essenti al to the operat ion of th ese fil ter ing opt ions, they must  

not  be deleted or rename d.  

 

 
Filter  typ e 

Check to modify th e kernel for a selected Fil ter typ e, eith er Conv olut ion 

or Morp hological filt ers. 

Edit Check to modify th e selected filter  kernel using th e Edit  Kernel dialog. 

  

 
Name  

This combo box  cont ains th e nam e of th e selected 

kernel file. I f one want s to save th e modified kernel file to 

th e sam e file, leave it  as it  is. I f one want s to save th e file 

to a new 

locati on, ent er th e new filename here. 
 

 
Kernel 

Size 

Click th e spin butt ons or ent er th e number to change th e 

size of th e kernel. Eith er directi on may take int o account 

one to nin e pixels. As one modifies th e Kernel Size, th e 

shape of the kernel represent ati on changes accord ingly. I n 
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  th e cent er of th e dialog, th ere are whit e boxes cont ainin g 

coefficient s th at  will be multi plied with each pixel th at  will be 

taken int o account  by the filt er  kernel. One can change any 

coefficient  by clicking on it  and adjust  it  as desired. 

 
 
 
 

Fill 

Click thi s butt on to fill every eleme nt  of th e kernel with a 

parti cular value. The Fill kernel dialog appears. One may 

ent er a value between 0 and 10 . Using th e Fill butt on is 

useful for settin g all coeff icient s to th e same value. One 

may then change th e coeff icient s th at  require a different  

value. 

 

 
Offset  

The pixel whose value is being modified is usually th e 

cent er-most  pixel. One may, however, designate any pixel. 

ALTRAview  signals th e pixel to be changed by puttin g a box 

around it . Choose the X and Y Off set  spin butt ons to app ly  

 

 
New 

Click to create a new filt er  kernel. The Edit  Kernel dialog will appear. The 

functi ons of the dialog are th e sam e way as th e dialog for Edit 

described above), with th e exception th at  th e file name for th e new 

kernel file must  be provided. 

Delete Click to delete th e selected filt er  kernel file. 

 
Options 

The choices in thi s group box will vary depending upon the kind of 
selected filt er. 

12.2. Stitch 

12.2.1. Video Stitch 

When the video window is active , choosing th e Process> Sti tch command will 

invoke th e video St it ch dialog as below:  
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Directi on :  The image st itching direct ionʼHorizontal or Vert icalˀThe defaul t  is 

Hor izonta lˀ 

Run The st itching run me thod:  Backgr ound or Foregro und. The defaul t  is 

Backgro undˀ 

Snap:  The captu red images fro m th e came ra;  

Snap Click to capture image fro m came ra ;  

Reset  When an ima ge or ima ges is or  are captu red, the Reset butt on wil l be 

enabled,  click Reset  wi ll rem ove it  or th em  fro m th e mem oryˀI t  will be 

disabled when there is no captured ima ge;  

OK Click Ok to begin ima ge stitching. This butt on  wil l be enabled only when 

th e snapped ima ges are more th an 2;  

Cancel Click to cancel the stitching pro cess;  

 

St itching finished image 
 

I n the stitched ima ge, there are some black areas.  These are happened when 

there are  tr anslat ions between the images  in both direct ions. 

12.2.2. Image Stitch 

When the image window is act ive,  choosing  the Process>S ti tch comm and wil l 

invoke th e image St it ch dialog 
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Available Images  The images opened by ALTRAview  

Selected Ima ges The images selected for stitchingˀ 

Add> >  When an ima ge or images is or are selected and highl ight ed in 

th e Available I ma ges window, th e Add> >  will be enable.  Click 

Add> >  will add it  or them int o th e Selected I mages windowˀ 

Add All> >  Click Add All> >  will add all of the Available I ma ges into th e 

Selected Ima ges window;  

Remove When an ima ge or images is or are selected and highl ight ed in 

th e Selected Ima ges window, the Rem ove but ton wil l be enabled, 

click Rem ove wil l rem ove it  or them fro m the Selected I ma ges 

windowˀ 

Clear Used to clear all of th e ima ges in the Selected I ma ges window. 

When no image in the Selected Ima ges window, it  wil l be 

disabledˀ 

Directi on  The ima ge stitching directi onʼHorizonta l or Vert icalˀThe defaul t  

is Hor izonta lˀ 

Run The stitching run method:  Backgr ound or Foregro und method. 

The defaul t  is Backgr oundˀ 

OK Click Ok to begin ima ge sti tching. Only the Selected Ima ges are  

more than 2, this butt on  wil l be enable;  

Cancel Click to cancel the stitching pro cess;  
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4 images for st it ching 
 

 

St itching finished image 

I n th e stitched  image, there are some black areas;  these are happened when th ere 

are  tr anslat ions between the images in both direct ions. 

12.2.3. Browse Window Stitch 

Clicking the Folders Sidebar to act ivate it . Double-click ing the r ight  director y to 

show th e ima ges under  the director y in the Brow se window. Choosing the image 

files to be s t itched and then clicking th e r ight  mouse but ton  will display the 

context  menu, c hoosing the Sti tch submenu to start  the ima ge sti tch pro cess (One 
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can also choose Process> St itch to do th e sam e operation  after th e files are 

selected in the Brow se window) . 

 

After  the Sti tch command is selected,  a dialog cal led Sti tch will popup. Choosing 

the r ight  directi on  and clicking OK to begin th e sti tching.  

 

The final  stitched ima ge wil l look like below 

 

12.3. EDF  Shift+E 

12.3.1. Browse Window EDF 

Clicking  th e Folders Sidebar to act ivate the Brow se Window. Double-clicking th e 

directory to display the images in the Brow se wi ndow in I con mode.  Choosing 

th e image files to be fused wi th Ctrl+ A (Select  all in the curr ent  directory )  or 

Ctrl+ left mouse but ton to select  the image one by one)  and th en clicking the 
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r ight  mouse b ut ton  wil l display a context  menu, choosing the EDF submenu to 

start  the ima ge f usion pro cess (One can also choose Process> EDF command 

to do th e same operat ion after the ima ge files are  selected in th e Brow se 

window). 

 
 

After the EDF command is chosen , a dialog cal led Select  Meth od is pop up as 

follows:  

 

There are 3 EDF meth ods in ALTRAview , th ey are:  
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Maximum Contr ast Maximum Contr ast  method is sim ilar  with weighted average 

method, and the input  images m ust  be in Z ord er as well . The 

diff erence is that  the maximum  contr ast  meth od may loose 

some  detail however the preserved deta ils wi ll be sharp er. 

Maximum Contr ast  method is a preferr ed me thod in th ese 

3EDF methods. 

Weighted Average Weighted Average me thod pro duces a soft  fusion  resul t  but 

may lose detail . This me thod often gives super ior result s to 

FFDSSD me thod with deep stacks, such as images prod uced 

by m icroscopy. I t  is wor th not ing that  ima ges to be pro cessed 

must  be in Z ord er (Captu re a ser ies images  in closest  to 

furthest  or fur th est to closest  ord er);  

FFDSSD FFDSSD is a me thod th at does filter ing in the fr equency 

domain using Fast  Four ier  tr ansfor m  (FFT)  and does synt hesis 

in the space domain. FFDSSD can be used for images having 

m isalignment. Users can ma nua lly or aut omat ical ly select 

reference im ages to ma ke ima ges aligned.  

12.1.1.2 Maximum Contrast 

 

Choosing  Maximum Contr ast  in th e Select  Method dialog wil l pop up an 

Opti ons Dialog as follows:  
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Detai l  Clarity Detai l Clar it y affects the fine detai l of the resul t. Default : 107, 

Range: 10~240 ;  

Total Br ightness Total Brightness is th e overall br ightness. The Detail Clar it y 

and Backgro und Br ightness wil l resul t  in the change of th e 

Total Br ight ness. For that reason, the Total Br ightness may 

also need to be adjusted. Default:125, Range:10~240 ;  

Backgro und 

Br ight ness 

Backgro und Brightness is the off set  value that  is used to add or 

subtr act  the backgro und. Default :  93 ;  Range: 10~240 ;  

Defau lt  This wi ll set  all 3 values to th e Defau lt  ones;  

Clicking Next>  button  wil l pop up an Auto Align  dialog as fo llows:  

 
 

 

None Considering  no  Shift+S cale+ Rotate  am ong  th e  selected 

images in the fusion pro cess;  

Shift+S cale Considering Shift+S cale am ong the selected images in the 

fusion  pro cess;  Rotat ion is not  condsidered in this opt ion;  

Shift+S cale+ Rota te Considering Shift+S cale+ Rotate am ong th e selected images 

in the fusion pro cess;  I f this mode is checked, The Maximum 

Angle slide bar wil l be enabled. 
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Maximum Angle The Maxim um Angle is used to set  the upper lim it  in Rotate 

al ignment . The Defaul t  is 1 degr ee.  Range: 0.1~10 ;  

The u ser can select  the prop er Auto Align mode according  to wheth er there is shift, 

scale or rotate am ong the images to be pro cessed.  The t ime consumpt ion of EDF is 

related to the sett ing of the Maximum Angle. The time will increase when th e 

Maximum A ngle increases and the relat ionship between them is non- linear. The 

defaul t  is 1.0° ;  

Clicking < Back wil l retu rn  to Opti on  dialog and clicking Fin ish will begin the 

EDF operat ing accord ing to the pr evious setup. ALTRAview  wil l display the 

EDF(Extended Depth of Focus)  progr ess bar as fo llows:  

 
 

The final  EDF result  is shown below:  

 
 

12.1.1.3 Weighted Average 

The setu p steps  of the Weight  Average are the sam e as those of the Maximum 

Contr ast. About  the setu p details,  please  refer to Maximum Contr ast  in 

Sec.12 .3.1.2. 
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12.1.1.4 FFDSSD 

Choosing  FFDSSD in th e Select Meth od dialog will pop up a FFDSSD Opt ions dialog 

as below:  

Determ ine the reference ima ge automati cally:  Before  EDF, FFDSSD will evaluate 

all th e images to determine  th e reference image fo r feature matching.  After 

the reference ima ge is determ ined, FFDSSD will perfor m  feature matching 

between th e reference image and the other ima ges to find the al ignme nt  

param eters 

The default  is checked.  I f the Determ ine th e reference image aut omat ically 

is unchecked , ALTRAview  wil l take the first  image as reference image in the 

al ignment  operation . 

 

Clicking Fin ish but ton wi ll begin th e EDF, an EDF (Extended Depth of Focus)  

progr ess bar dialog wi ll display as follows:  

 

The final  EDF result  is shown below:  
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12.3.2. Image Window EDF 

Similar  to the Brow se window EDF, I ma ge window EDF is also a very useful tool 

to generate a c lear ima ge by combining a sequence of previously captu red or 

opened m ulti -focus ima ges. Choosing th e Process> EDF comm and,  the followi ng 

dialog wi ll be bro ught up (assume 01 .jpg 02.jpg é 15.jpg are already 

opened in ALTRAview ):  

 

 

Clicking on the ima ge file name in the Open combo box  will highlight  the image,  

and th en the Add> >  but ton  is enabled (Click on the selected ima ges wi ll deselect  
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them). Click  the Add> >  but ton, th e highlighted ima ges wil l be added into the 

Selected list box,  which will be fused later. 

Clicking  the Add all but ton wil l add al l images in th e Open combo box  int o 

th e Selected list  box. 

I f images  in th e Selected combo box  are highl ight ed,  th e Delete but ton will 

be e nabled.  Click the Delete butt on, the highl ighted im ages in the Selected combo 

box  wi ll be removed. 

Clicking  the Clear butt on  wi ll rem ove all the images in th e Selected list  box,  

including th e unselected ones. The butt on wi ll be disabled if th ere is no im age in 

the Selected combo box . 

When  the desired ima ges are al l selected (I f more than 2  ima ges are added in 

th e Selected List  box, the Next>  but ton  will be enabled), clicking on the Next>  

but ton wi ll start  EDF pro cess. 

ALTRAview  will display the EDF(Extended Depth of Focus)  progr ess bar as follows:  

 
 

The final  EDF result  is shown below:  

 
 

NOTE:  I mages used for fusing m ust  be the sam e size;  otherw ise there wi ll be 
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a pro mpt  when adding different  sizes of ima ges as below. The pro mpt  dialog 

indicates w hich image is not  the sam e size wi th the others. 

 

 
 

12.3.3. Video Window EDF  

Make  sure th at  the ALTRAview  package and UCMOS or UHCCD came ra are corr ect ly 

insta lled.  Turn on  the m icroscope's light . 

1.  Run ALTRAview  and start  the came ra;  

2.  Choosing the Process> EDF command or clicking   on the toolbar will br ing up 

a dialog called ñCaptu re I mageò;  

3.  Use the m icroscope coarse or fine focus knobs to move the sam ple stage up 

and down, in ord er to find th e posit ions where the clearest  regions of the 

whole sam ple can be seen on  the Video window;  

4.  Click  the Captu re but ton to capture an ima ge in to th e ima ge list  which wi ll be 

used for the EDF operat ion. 

 

5.  Unless there is 1 captured im age,  the Clear but tons wil l not  be enabled. 
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Unless th ere are more than 2 captured ima ges, th e Next>  buttons wil l not  be 

enabled. I f th e captured images are not  sat isfactor y, click the Clear butt on  

to clear the captured image(s), and capture new ima ge(s) . 

6.  I f more than 2  ima ges are captured,  Clicking Cancel wil l end the Capture 

I ma ge and return to the Video window. I f the Next>  but ton  is clicked,  ALTRAview  

will pop up a  dialog called Selected Method to begin the EDF configur at ion  

pro cess. About th e configur at ion detail , please check Brow se Window EDF in 

Sec.12 .3.1. 

The final fused  ima ge wi ll be displayed in a new act ive ima ge window and its t it le 

bar wi ll be associated wi th a digit  assigned by ALTRAview . 

 
 

Note:  a) . Use the coarse and fine focus knobs  to move the sam ple stage up and 

dow n; b ). Click ing the Captu re butt on  wi ll capture th e curr ent ima ge int o the 

image fusion list ; c ). Repeat ing steps 1-4 unti l there are enough ima ges; d ). 

Clicki ng the Fusion but ton  will start  ima ge fusion. Wait ing for some t ime and a 

fant ast ic fusion result  will be displayed in a new image window;  

12.4. Segmentation & Count 

Choose the Process>S egmentat ion  & Count command to real ize the 

segmentat ion and count  of the in terested image. The arrangem ent  of 

Segmentat ion & Coun t  is very special and some  explanat ions are needed here to 

clar ify it  in deta ils:  
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1.  The function  prov ides users wi th five methods which are Watershed(W), 

OTSU Dark, OTSU Bright , RGB Histogram, HSV Histogram and Color Cube. 

Users can select any one of th ose 5 methods, but after selecting any one of 

th em, the oth ers wi ll be disabled. 

2.  After segmentation , there m ay exist  adhesions. Then what  we should do 

is segme nt  connected object  manua lly by choosing th e Split  Objects functi on. 

3.  When the users  get  the expected resul ts,  they can choose the Counti ng 

Resul ts menu and get  the stat istics and analysis resul ts. 

According to the counting  result , you can go back fro m step 2 or 3 to step 1 or 2 

to repeat segmentati on  or split  ob jects operati on. 

Note:  I f th e users  choose None in the Label butt on  at the Count  Opti ons dialog, 

th en regard less of th e typ e of Method set, there is no Label for  Index, Area or 

Per imeter on th e ima ge.  But  the None, Circle and Ell ipse wi ll show the segmentati on  

results. Thatôs w hy ALTRAview  name  the me nu as Segmentat ion & Count . That is, 

this funct ion can achieve either the image Segmentat ion or Coun t. I n this regard,  

please refer to th e Process>S egmentat ion  & Count  >  Watershed(W) in the Count  

Opt ions dialog.  

12.4.1. Watershed(W)  

Watershed segmenta ti on  method is a mathem at ical morp hology 

segme nt at ion method, which based on topological  theory. The basic idea is taking 

th e ima ge as a topo logical geomorp hology on geodesy, and each ima ge pixel 

gr ay value indicates th e alt itude,  boundar ies of each local m inimum value and 

its impact  area cal led c atchme nt basins and th e for m at ion  of watershed 

catchment basins. So  th e for mat ion of th e watershed concept can be illustr ated 

by simula ting the imme rsion pro cess. I n each local m inimum value of the surf ace, 

piercing a hole,  then the enti re model slow ly imme rsed in water, with the 

imme rsion of th e deepening impact  of th e domain of each local m in ima  slowly 

expands out ward in two catchments basin at th e confluence build dam s tha t fo rm  

the watershed.  

Watershed is sui table for relatively  simple backgro und targ et  object  or target  

objec t w ith a relat ively large diff erence between the backgro und images instead 

of th e more complex app licati on.  
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Choose Process>S egmentat ion & Count  >  Watershed(W)é, th ere wi ll pop up 

th e followi ng dialog:  (Note:  Segmentat ion & Count  funct ion only work s for 24 

bits, o th erwise al l the sub-menu it em s wil l be disabled. Users can  change the Color 

Bits to 24 bits by choosing Ima ge> Mode>C olor Quant izeé)  

 
 

Appr oximat ion  Appr oximat ion  including three opti ons:  1)Noneʿdrawn th e actual 

outl ine of the segment ed object 2ˀ)Circle Tʿhe actua l outl ine fitti ng 

in to a  perf ect  circle, users can get  f it  Radius of each object  in the 

Count  Resul t  dialogˀ3)EllipseʿThe actual outl ine fitt ing into a 

el lipse, users can get  fit  Axis of each obje ct  in th e Count  Result  

dialogˀ 

With Holes When checking With Holes functi on, th e segmented obje ctôs 

Outl ine will be marked with Color. Meanwhil e th e holes are also 

ma rked with Color and it s parame ters will be out put in th e image 

(Hole is defined as th e target grayscale or th e color close to th e 

background pixels). The left  figure below is th e segmenta ti on result 

with out  checking Wit h Holes;  th e right  below is on th e contrary. 

With Holes option is usually used to get  hole parameters;  

 

http://www.jukuu.com/show-contrary-0.html
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Outl ine Style:  I ncluding 3 opti ons:  1)Out line:  objects are marked by 

outlin e, th e color can be user-defined;  2)Filledʿth e segment ed 

objects will be filled with custom colors 3ˀ)None nʿo ma rk ed outlin e 

for th e segme nt ed object;  

Color:  Custo m colors used to ma rk th e Style;  

Label Meth odʿI ncluding 3 opt ions: 1)XORʿwith th e cur rent  pixel's XOR 

color to ma rk th e current  object  segme nt ati on; 2)Trueʿ  marked 

with th e specified Color;3)False:  no ma rk for  th e objects;  

NoteʿI f users choose False in the Label group box, th en regardless 

of the typ e of Method, th ere is no display for I ndex,  Area or 

Per imeter. But  th e None, Circle and Ellipse will displayed on th e 

segme nted ima ge. Thatôs why ALTRAview  call it  Segment at ion & 

Count ;  

Color:  Custom  Color used to represent  the color of Label. When 

selecti ng XOR in the Method, the Color selecti on wil l be disabled, 

but  the ALTRAview  wi ll au toma ti cal ly mark the segmented image 

with the curr ent  pixelôs XOR color ;  

Typ e:  I ncluding 3 opt ions:  1)  I ndex:  use numbers to ma rk the 

segme nted object.  2)  Area:  the object area is ma rk ed by outli ne 

area size.  3) Per imeter:  the object per imeter is ma rk ed by the 

outl ine perime ter;  

Area Min imum:  determine th e lower lim it  of the area. th at is,  if the 

object  area is less than the lower lim it  , it  wi ll not  be included; 

Maximum:  determ ine the upper lim it  of the area. th at  is,  if th e 

object  area is gr eater th an the upper lim it  , it  will not  be included;  

Per imeter Min imum:  determine th e lower lim it  of the perimeter. th at  is,  if the 

object  perime ter is less than the lower lim it , it  will not be included; 

Maximum:  determ ine the upper lim it  of th e perimeter. that  is,  if 

th e obje ct  per imeter is greater than the upper lim it , it  wi ll not be 

included;  

The figure below shows image Segment at ion & Coun t results with watershed 

meth od w ith sett ing in Count  Opt ion dialog . 
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12.4.2. OTSU Dark 

OTSU is propo sed in 197 9 by Japanese scholars , which is a method to determ ine 

th e threshold of an adaptive,  also known  as Otsu method, referr ed to as OTSU. 

I t  is based on the gr adat ion character ist ic of the image,  and divided the image 

into th e backgro und and the targ et. The bigger th e OTSU is between 

backgr ound and th e target , the larg er difference between th e two parts im ages. 

The wr ong part  of the th e backgro und or the wro ng part  of the targ et  wil l lead to 

smaller  differences between th e two parts. Therefor e,  the maximum OTSU 

means the min imum probabilit y of m isclassificat ion. 

OTSU Dark segmentation  method me ans segme nt  the dark object  fro m  the 

br ight backgro und using OTSU algor ithm.  I ts Count  Opti ons dialog is exactl y the 

same with th e Watershed Count  Opti ons. Below are br ight  backgr ound wit h dark 

object  (bot tom left)  and its segmentat ion result  (bott om  right)  for  reference:  

 
 

12.4.3. OTSU Bright (B)  
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OTSU Bright  segmentation  method  me ans segment  the br ight  obje ct  fro m  the 

dark backgro und using OTSU algor ithm.  I ts Count Opti ons dialog is exactl y the 

same with th e Watershed Count  Opti ons. Below are dark backgro und with br ight  

object  (bot tom left)  and its segmentat ion result  (bott om  right)  for  reference:  

 
 

12.4.4. RGB Histogram 

RGB Histogr am segmentation  is based on image histogram where ima ge 

pixels between a specified histogr am upper and lower range will be color 

pro cessed.  The segme nted area can be adjusted by mouse to drag two vert ical 

lines in histogram , or by inputti ng pr ecise value in RGB upper and lower edit  

box directl y and clicking ñEnterò to make it  effect ive.  The Color repr esent ing th e 

segmentat ion area can be custom ized by system  palet te.  For a 24-bit  true color 

ima ge,  segmentat ion can be realized by RʼGʼB channels respect ively. 

Choose  Process>S egmentat ion & Coun t>R GB HistogramÅÅÅ shows Histogram 

dialog, e ach funct ion  is specified as below:  
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 Left  Value  in  the  currently  selected  region  of  histogram 

segmentation, corresponding to Left Vertical Line position in 

histogram. Users can segment  the pixels bigger than the Left 

value by input ting a value in th is edit  box or dragg ing the Left 

Verti cal  Line in histogram. When input  a Left  Value in this edit 

box,  users should click enter to make the value effect ive. 

Meanwhi le,  the Left  Verti cal  Line wil l move to the place th e Left 

Value represents.  Left  Value range:  0~ curr ent  Right  Value. The 

curr ent  Left  Value is 0;  

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Right  Value in the curr ent ly selected region of histogram 

segme nt at ion, corr esponding to Right Vert ical Line posit ion in 

histogram. Users can segment  the pixels,  bigger than the Left 

Value and sm aller than Right  Value, by inputt ing a value in th is 

edit  box or dragg ing the Right  Vert ical Line in histogr am.  When 

input  a value in th is edit  box,  users should click enter to make th e 

value effect ive . Meanwhi le,  the Right  Vert ical Line wil l move to 

th e place th e Right  Value represents.  

Right  Value range:  curr ent  Left  Value ~255 . The curr ent  Right  

Value is 79 ;  

 
 

 

A histogram channel of the curr ent ly RGB histogram. I t  can be R 

histogram, G histogram or B histogram;  

 

 
 

Show all channel RGB histogram.  When uncheck Show All, only a 

selected histogram channel wi ll be shown;  

 
 

 

Used to ident ify the Color of th e segmented pixels;  The default  is 

gr een;  

 
 

 
 
 
 

When users  click Opt ions¹  but ton, a Count  Opt ions dialog pops 

up as below. The sett ing of Coun t Opt ions dialog is the sam e as 

tha t  of Waltershedôs Count  Opt ions dialog, details can be referr ed 

to Process>S egmentat ion & Count> Watershed(W)¹;  
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Exam ple of RGB Histogram is as follows :  

1.  Open  an  ima ge  and   then  choose  Process>S egmentat ion  &  

Count ing>R GB Histogram¹  me nu, a Histogram dialog shows as below. When 

the mouse moves in th e image area, the cursor wil l be displayed as Color Picker 

Cursor;  

 

2.  Move Color Picker Cursor to any pixel of the image , shown  as above, RGB value 

of th e curr ent  pixel wi ll be displayed in the bott om  Histogram window. Here R is 

249ʼ G is 51ʼB is 31 , showing the RGB value of the ideal  segmentat ion area, 

record the three values.  

3.  Move the  mouse  to the backgr ound area, the RGB value of Color Picker Cursor is 

79 , 79 , 79 . I n ord er to accurately segme nt out th e target, users can set  RGB 

values of th e segment ed pixels in the in itia l interval, and those of backgro und 
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out  of th e ini t ial in terval. For exam ple,  th e RGB values can be set  to the ini t ial 

interval as follows:  

R is set  to the in iti al int erval:  20 0~255;  
 

G is set  to the ini t ial in terval:  0~60 ;  

B is set  to the ini t ial in terval:  0 ~  60 ;  

When setting  completed,  the segmentat ion  effect is shown  as below:  

 

4.  Move  again the Color Picker Cursor to any  other unshaded pixels, then the RGB 

value shown  in left  bot tom of histogram is 237 , 70 , 45 as below :  

 

Itôs easily found that  here G channel, defined 60 , is too small to get  the pixel 

segme nted.  Then in iti al in terval for G channel can be adjusted fro m 0~6 0 to 0~8 0 to 

segme nt  the pixels nearb y. (Note:  I f th e backgr ound pixels of a single channel is 

withi n th e ini t ial interval, no segme nt at ion  change wil l take place.  Only al l th ree 

channels of th e backgro und pixels are wi thin the in iti al int ervals can the pixels be 

segme nted)  The segmenta ti on eff ect  by readjusting G ini ti al int erval is shown as 
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below:  

 

5.  Repeat  step 4 and readjust  init ial int erval of each RGB channel to achieve 

perf ect segme nt at ion. 

12.4.5. HSV Histogram 

HSV Histogram segmentat ion is based on image histogr am where image pixels 

between a specified histogr am upper and lower range will be color pro cessed.  The 

segme nted area can be adjusted by mouse to drag two vert ical lines in histogram , or 

by inputti ng pr ecise value in HSV upper and lower edit  box direct ly and clicking 

ñEnterò to make it  eff ect ive.  The Color represent ing th e segmentat ion area can be 

custom ized by system palet te.  For a 24 bits true color ima ge, segmentat ion  can be 

realized by HʼSʼV channels respect ively. 

Choose  Process>S egmenta ti on  & Count > HSV Histogr amÅÅÅ shows Histogram dialog, 

each funct ion is specified as below:  
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Left  Value in the currently  selected region of histogram 

segme nt at ion, corr esponding to Left  Vert ical Line position in 

histogram. Users can segment  the pixels bigger than the Left  

value by input ting a value in th is edit  box or dragg ing the Left 

Verti cal  Line in histogram. When input  a Left  Value in this edit 

box,  users should click enter to make the value effect ive. 

Meanwhi le,  the Left  Verti cal  Line wil l move to the place th e Left 

Value represents.  Left  Value range:  0~ curr ent  Right  Value. The 

curr ent  Left  Value is 0;  

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Right  Value in the curr ent ly selected region of histogram 

segme nt at ion, corr esponding to Right Vert ical Line posit ion in 

histogram. Users can segment  the pixels,  bigger than the Left 

Value and sm aller than Right  Value, by inputt ing a value in th is 

edit  box or dragg ing the Right  Vert ical Line in histogr am.  When 

input  a value in th is edit  box,  users should click enter to make th e 

value effect ive . Meanwhi le,  the Right  Vert ical Line wil l move to 

th e place th e Right  Value represents.  

Right  Value range:  curr ent  Left  Value ~255 . The curr ent  Right  

Value is 79 ;  

 
 

 

A histogram channel of th e curr ent ly HSV histogr am.  I t  can be H 

histogram, S histogram or V histogram;  

 

 
 

Show al l channel HSV histogram.  When uncheck Show All, only a 

selected histogram channel wi ll be shown;  

 
 

 

Used to ident ify the Color of th e segmented pixels;  The default  is 

gr een;  
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When users  click Opt ions¹  but ton, a Count  Opt ions dialog pops 

up as below. The sett ing of Coun t Opt ions dialog is the sam e as 

tha t  of Waltershedôs Count  Opt ions dialog, details can be referr ed 

to Process>S egmentat ion & Count> Watershed(W)¹;  

 

Example  of HSV Histogram is as fo llows:  

1.  Open  an  image   and  then  choose  Process> Segmenta ti on  &  

Counti ng> HSV Histogram¹  me nu, a Histogram dialog shows as below. When 

the mouse moves in th e image area, the cursor wil l be displayed as Color Picker 

Cursor;  

 

2.  Move Color Picker Cursor to any  pixel of the ima ge, shown as above,  HSV value 

of th e curr ent  pixel wi ll be displayed in the bott om  Histogram window. Here H is 

18 6ʼ S is 114ʼV is 206 , showi ng the HSV value of the ideal segmentat ion area, 

record the three values.  
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3.  Move the  mouse to the backgro und area, the HSV value of Color Picker Cursor is 

214 , 87 , 228 . I n ord er to accur ately segment  out the target , users can set  HSV 

values of th e segment ed pixels in the in itia l interval, and those of backgro und 

out  of th e ini t ial in terval. For exam ple,  th e HSV values can be set  to the ini t ial 

interval as follows:  

H is set  to the init ial interval:  60~20 0;  

S is set  to the initial  interval:  90~13 0;  

V is set  to the initial  interval:  0~21 0;  

When set ting completed , the segmentat ion  effect is shown  as below:  

 

4.  Move again  the Color Picker Cursor to any other  unshaded pixels, then th e HSV 

value shown  in left  bot tom of histogram is 194 , 79 , 212 as below:  

 

Itôs easily found tha t  here S channel, defined 90~ 130 , its lower lim it  is too bigl to get 

th e pixel segmented . Then in it ial in terval for  S channel can be adjusted fro m 90~130 

to 60~13 0 to segme nt  the pixels nearb y. (Note:  I f the backgro und pixels of a single 

channel is wit hin the ini t ial interval, no segmenta ti on  change wi ll take place. Only all 
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three channels of th e backgr ound pixels are with in the ini t ial int ervals can th e pixels 

be segmented)  The segme nt ation effect by readjust ing S in it ial interval is shown  as 

below:  

 

5.  Repeat  step  4 and readjust  init ial interval of each HSV channel to achieve 

perf ect segme nt at ion. 

12.4.6. Color Cubic 

Choose Process>S egment at ion & Count >C olor Cubeé, a dialog called Color will pop 

up as below;  

 

 

At this moment , th e Color izing Pipett e (Default )  is checked by default . Click th e 

image wi ll set  the average color value in the masked area as Basic Value. ALTRAview  

wi ll segment  the image by choosing th e pixel with in Basic Value°Tolerance color 

range and mark it  wi th current  selected Color. By clicking the target  pixel repeatedly, 

ALTRAview  can continuously add new pixels within the Basic Value°Tolerance color 

range into th e target and thus acquir ing continuous segmentat ion  color izing. 

When some  undesirable  pixels have been added into the segmentat ion  data, the 

De-Color izing Pipet te can be used to wipe of f the undesirable pixels. This operat ion 
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pro cess is the sam e as Color izing Pipet te, that is,  to set the average color value of the 

clicked-pixelôs Mask Area as Basic Value and wipe of f th e segmentati on  data, which is 

withi n the Basic Value°Tolerance color range.  

 

 
 

 

Color izing Pipet te:  Collect  average color value of th e clicked-pixelôs 

Mask Area as Basic Value and add pixels which are withi n Basic 

Value°Tolerance color range int o th e segme nt ati on data;  

 
 
 
 

 

De-Color izing Pipette :  Collect average color value of th e 

clicked-pixelôs Mask Area as Basic Value and wipe off th e 

segme nt ati on data, which is withi n th e Basic Value°Tolerance color 

range;  

 

 
 
 
 
 
 
 
 
 

Mask Area:  When Color izing Pipet te or De-Color izing Pipet te is used 

to click the ima ge, a Mask Area is also needed to calculate th e 

average color value of th e clicked pixel. The Mask Areaôs color value 

will be used as Basic Value. Color values withi n th e Basic 

Value°Tolerance range can be added to or wiped off fro m  th e 

segme nt ati on data. The default  Mask Area is 3* 3, oth er option s are 

1*1ʼ5*5 ʼ7*7 ;  

RGB The average RGB values of th e Mask Area;  

Tolerance There are 3 Tolerance values, th ey are R, G and B. User can ma ke 

fast  and accurate object  segme nt ati on by selectin g a proper 

Tolerance value according to their  experience. The default  R, G and B 

Tolerance values are 10 ;  

 
 

 

Used to ma rk th e color of th e segme nt ati on area;  The default  Color is 

green;  

 
 
 
 

 

When clicking th e Opt ions but ton, a Count  Opti ons dialog as below 

will pop up. This dialog is th e same as th at  in Process>S egme ntat ion 

& Coun t> Watershed (W )... . Please refer to Process>S egme nta ti on  

& Coun t> Watershed (W)é for th e detailed operati on of thi s dialog;  
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Here is an example  to dem onstrate the Color Cubic segme ntat ion  pro cess:  

1.  Open an image  as below:  

 

 
2.  Because of the inevitable noise in th e image, an image sm ooth operat ion  

should be done first . There are many algorith ms to perfor m  the image smooth 

operat ion and here we are to pro cess it  as follows: choose Process> Filter 

me nu and  c lick Morp hological prop erty page and a dialog wil l pop up wi th 

param eters as shown  in th e figure below on the left  side.  Click OK and the 

final smooth ed image is shown below on the right  side. 
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3.  Choose Process>S egmentat ion  & Count>  Color Cubeé, a Color dialog  will pop up 

as shown below;  

 
 

4.  At this moment , the Color izing Pipet te is checked. Click th e pixel wish to 

segme nt . that  is to say, select  the color area which is interested in. I f some 

undesirable color area is included in th e segment at ion area, just  check the 

De-Color izing Pipet te and click the undesirable pixels,  thus the undesirable 

pixels wi ll be wiped of f. When th e segmentat ion pro cess is completed,  click OK 

and the Segmenta ti on  & Count  operati on  will be carr ied out. 
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The result  of segme nt ati on after th e first 

clicking   at   th e   point ed   area   with 

Color izing Pipet te 

The  resul t  of  segment ati on  after  th e 

second clicking at  th e point ed area with 

Color izing Pipet te 

 
 

 
 

The result  of segme nt ati on after th e 

second with th e De-Color izing Pipett e 

(s light  difference exists as inaccuracy in  

posit ion)  

The result  of segme nt ati on after countl ess 

clicking wit h Color izing Pipet te 

5.  Click Opt ions to set Outli ne, Label and etc., th e final  resul t is shown below. So far 

th e pr imary segmentat ion is completed.  
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12.4.7. Split Objects 

I t  can be fou nd out  in this segmentation , part icle #1 6 (l ocated in the upper m idd le 

of th e image)  is not  a single object  but actu ally two separate one.  However they 

have been calculated as a single obje ct . Choosing Split  Objects wil l corr ect  this 

problem . Object spli tti ng wit h Spli t  Obje cts is discussed below. 

As is shown  in the image  below, move the cursor onto targ et  #16 . Click the 

left mouse but ton  and draw a st raight  line. When pressing  dow n th e left  mouse 

but ton, the cursor should not  touch the target  Ê the starti ng point  of the split  line 

should be of f the target tha t is to be separated. Move the cursor to the bott om 

r ight  of the targ et Ê th e ending poin t  of the split  line should also be of f the targ et 

tha t  is to be separated.  Release th e left  mouse butt on w hen this operat ion is 

completed.  A split  line is shown  between the two adhesive objects as shown 

below:  
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After th e left  mouse  but ton is released,  ALTRAview  wil l re-count  th e whole im age. 

The result  of re -count ing is shown as below. The previous #1 6 turns out  to be 

#1 2 and #1 7 now:  

 

Unchecking  or  choosing Split  Objects menu again wi ll hide th e split  line.  The 

final result  of hiding the spli t  line is shown  as below. The whole Split  Objects 

pro cess is completed when the split  line is hidden. 

 

12.4.8. Count Result (T)  

Count  Result  is a way to show count  stat ist ical result  of the current  image. Count  

Resul t  dialog includes I ndexʺCenterʺRadius (major-minor axis or non), Area and 

Perimete r, as is  shown below. The un it  of stat ist ical result  is the same as what  the user 

select s in  the Unit  for the displayed image. Click I ndex ,  Center ,  Radius (major-mi nor 

axis or none) , Area and Perimeter and  the stat ist ical result  will be automat ically sor ted 

according to their  data . Choosing a certain  item can check the split  objec t  in  the image. 
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I n the meanwhile, Index  (or Area and Perimeter)  of the other targets will  be hidden 

automat ically. 

 

The  Cent er column in Result  is relevant  to the Appr oximati on  opt ion in  the 

Opt ions dialog. When selecting Circle, radius of the circle will  be liste d as Radius 

column and when choosing Ellipse,  major-minor Axis of the Ellipse will be listed as Axis 

column;  when select ing None,  no  column shows up. 

Click  Expor t  and  then the stat ist ical res ult , together with the i mage of Segmenta ti on 

& Count ,  will  be expor te d to an Excel sheet  for fur ther ana lysis and processing. 

12.5. Image Stacking 

The image-stacking  meth od is a for m of speckle ima ging commonly used 

for obtaining high qua lity images from a number of shor t  expo sures wit h vary ing 

image shifts.  I t  has been used in astronomy for several decades, and is the 

basis for the image stabilizati on  feat ure on some came ras. The method involves 

calculat ion  of th e d iff erent ial shifts of the ima ges. This is easily accomplished in 

astronom ical  images si nce they can be aligned wi th the stars.  Once the ima ges 

have aligned,  they are averaged together. I t  is a basic pr inciple of stat ist ics that  

var iation in a sam ple can be reduced by averaging together th e individual values. 

I n fact , when using an average, th e signal- to-noise rat io should be increased by 

a factor of th e square root  of the nu mber of images. 

I ma ge stacking can also be used for  biological m icroscope image and 

florescent m icroscope ima ge to increase th e ima ge SNR and dynam ical ranges;  

this is why we in troduce ima ge stacking int o ALTRAview . 
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ALTRAview  I ma ge Stacking introduced  adv anced ima ge ma tching techniques 

for rotated,  shifted and scaled ima ges. The user can record a  shor t  video to get a 

high q ual it y stacked ima ge at  ease without  consider ing the ima ge ro ta ti on, 

shift ing and scaling between a series of ima ges in the video. The steps of I ma ge 

Stacking are descr ibed as below :  

1ʽ  Choose Processing> I ma ge Stac kingé menu, a Windows Open dialog will pop up 

as shown  below ;  

 

2ʽ Choose the r ight  v ideo file recorded  befor e in the Open dialog,  here we can open 

ñtest. aviò for  dem onstr ati on, click Open to open the avi  file;  

3ʽ Then an I ma ge Stacking dialog will pop up to show th e progr ess of the each 

imageôs stacking progr ess. 

 

4ʽ I f Cancel is pressed , th e Image Stacking will be canceled.  After th e stacking is 

f inished,  a stacked image will be displayed in a new window for fur th er 

applicat ion. The final image is shown as below. One can find th e stacked ima ge 

signal to noise rat io is great ly impro ved.  From th e stacked ima ge has some black 
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edges, th is is because the ima ges in the video is moved and in th e stacking 

pro cess, ALTRAview  wil l added 0 to the ima ge area tha t  has no corr esponding 

pixel in the reference ima ge (we choose the first ima ge in the video file as the 

reference image). 

 

Note:  

1.  ALTRAview  suppor t wmvʼasfʼaviʼmp4ʼm4vʼ3gpʼ3g2ʼ3gp 2ʼ3gppʼmovʼ 

mkvʼflvʼrmʼrmvb for I ma ge Stac king operati on;  

2.  I n the Ima ge Stacking pro cess, ALTRAview  takes the first  frame as the 

reference image, this me ans the first fram e is very impor ta nt and should be assure 

the first frame  to be th e right  im age scene and the subsequent  frame s have a 

gr eater over lap region wi th the first  frame.  

12.6. Color Composite 

Use the Color Composite dialog box to create and configure color composites using 

black and whi te source images. You can access the Color Composite dialog box 

through the Color Composite menu item  fro m the Process menu. 
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You can combine  gray-scale ima ges into a color composite.  Any gr oup of gr ay-scale 

images that are of the sam e size can be m ixed in a  color composite.  I ma ges of 8 -, 

12 - , 16 -bit  integer or f loating point  for mat  are combined into a 24-bit  color 

composite.  Each input  channel will have individual LUT adjustments,  as well as a 

registr ati on  off set  to line it  up with the rest  of the images. 

 
 

You can  also combine individual channels fro m a single ima ge.  Each channel wil l be 

listed separately, as shown here:  

Source I ma ges:  The Source Images combo box displays th e images avai lable for 

color m ixing.  The Source Image list  is init ial ly fil led with a list  of the gr ay scale 

images that are curr entl y open. The size of th e color composite is determ ined by the 

first  input ima ge selected. Once this is entered, the list  is fil tered to cont ain only 
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images of the sam e size as the init ial select ion. 

Add:  Click the Add butt on  to add  an image to th e m ix.  You wil l be pro mpted for th e 

color to be assigned to tha t ima ge fro m the Set  Color dialog.  

Delete:  Use this button  to delete th e selected image fro m th e list . 

Color s:  The Color s combo box  displays  the images selected for color m ixing. 

 
 

To change the color within  the list  box, double-click to select  the ima ge nam e (t he 

Select  Color dialog box appears)  or highl ight  the nam e and click th e Set  Color but ton.  

To delete colors / images fro m th e Color s list  box, f irst  click on  the color/ ima ge to 

highl ight  it  then press the Delete but ton  with in the Color Composite dialog box. 

Color Bar:  The picture  item  box on the left  side of the Color s list  indicates the color 

associated wi th each ima ge in th e composite.  The Color Bar wil l scro ll wi th the 

contents of the Color s list  box. 

Set  Color:  This opt ion determines  the Color value used for the selected channel in th e 

fina l image display. Clicking on th e Set Color but ton br ings up th e Select Color dialog 

box.  
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Directly  select  a color by:  

 
1)  Dragging th e Color Value Slider to the desired color on the Color Bar (r ange of 

0 to 359 °) :  or  

2)  Clicking the appropr iate Color but ton on the Color Palet te. The Color 

Bar represents Color degr ees in th e standard color wheel repr esentati on, and th e 

Color Palet te conta ins a subset  of possible Color s (pure red,  gr een, blue, cyan, 

magent a, and white) :  or  

3)  Select  a dye in the dye list, and click the Select  Dye butt on. 

Note:  You can navigate through the Select Color dialog box by using the < Tab>  and 

< Shift  +  Tab>  keys to cycle through  the items  in the dialog box.   

In tensit y is determined  by the im age th e Color is applied to, and satu rat ion  will 

always be 100 % . 

The only exception  to this  is th e ñwhi teò Color, which has by definit ion a sat ur ati on of 

0%.  Selecting a value greater th an or equal to 36 0 (dragg ing th e Color Value slider 

over to the far r ight)  is a choice of whi te,  which resul ts in a non- t inted (gr ay) image. 

The elements  of th e Select Color dialog box are:  

Color Bar:  The Color Bar shows a rainbow displaying  the Color s underneath th e 

approp r iate point  of th e Color Value slider. 

Note:  

I f Color Value Slider is the selected (highlighted)  selected contro l, then you can 

also cont rol th e slider with keyb oard strokes:  
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Use the left / r ight  arro w < ->  or < -> keys to move the slider increm ental ly.  

Press th e < Page Up>  and < Page Dow n>  to move the slider in ñchunkò sect ions along 

th e Color Bar. 

Use the < Home >  and < End>  keys to move th e slider to the beginn ing and end of th e 

Color Bar. 

Selected: This color  block displays the new Color selected by the Color Value slider 

bar or the Color Palet te. 

Selected Color :  The Selected Color text  field  displays the corr esponding nume ric 

Color value of the Selected color block descr ibed above. The Selected Color value is 

expr essed as an HSV color, wi th the red value first, followed by th e gr een and blue 

values.  I f th e color corr esponds to a dy e color, the dye name wi ll be displayed.  I f th e 

dye color corr esponds to a color palet te color, the name of the color wi ll also be 

displayed.  

Curr ent :  The Curr ent  color block  displays the start ing Color of th e channel. 

Color Palet te:  The Color Palette pro ves an alternate  meth od of select ing a Color. 

Clicking on an item  in the Color Palet te will set the Color Value slider to the corr ect 

value and update the displays in both the Selected color block and Selected Color 

text  field.  

For example , clicking on th e whi te but ton on  the Color Palette wi ll set  th e Color Value 

slider to th e r ight , change the Selected color block to white,  and cause the Selected 

Color text  box to display ñWhiteò. 

Adjust :  The controls  in this sect ion are used to adjust  th e color composite 

cont r ibut ion  fro m each image, or for the color composite preview itself. You can 

adj ust  the input  image th at  is curr entl y selected in th e Color s list  by clicking th e 

selected but ton. When you want  to adjust  the color composite preview, or you want 

no image is selected in the Color s list, use the All but ton. 

Registr at ion:  Registr at ion  allows  you to corr ect fo r m is-registr ati ons of images 

caused by filt er- induced opt ical shifts.  Use the direct ional keys to shift  the selected 

image in the x-  and/ or y-  direct ion, with respect  to th e rest  of the input  ima ges. One 

click moves th at  channel one pixel in the direct ion indicated. Blank areas are filled 

with black.  The key labeled ñ0,0ò will re-center the selected image.  

The registration  shift  fo r the selected channel or the overall image is displayed in the 
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stat ic text  box below the direct ional keys. 

Cont rast :  Use the BCG sliders along wit h the Best  Fit  and Reset  but tons to adjust  the 

cont rast  of the selected ima ge or the composite . 

BCG sliders:  The Brightn ess, Cont rast , and Gam ma  sliders are  th e sim ilar  to the 

Cont rast  Enh ancem ent  feature in ALTRAview . You can also adjust  each channel 

individua lly or collect ively by using the Selected or All radio but tons (t o the left  of the 

BCG sliders in the Adjust  gro up box). 

Best Fit:  Click th is button  to perfor m a Best-Fit  contr ast  stretch on  the selected input, 

automat ically setti ng the Brightn ess and Contr ast  set t ings accordingly (Gam ma  will 

be reset to 50.) . This meth od is identi cal  to the Best Fit  contr ast adjustment under 

th e standard Contr ast Enhancement  feature of ALTRAview . Best Fit  is useful for f irst 

pass adjustments.  

Reset :  Pressing the Reset  butt on  automatically  resets the BCG setti ngs.  I f th e Adjust  

radio but ton is set  on  All, the BCG sett ings for the overall color ima ge wi ll be reset . 

Fram e:  Use the frame slider  to adj ust  the fram e of the selected image that  is used for 

th e pr eview, or the active fram e of the composite.  (Please see the discussion of Color 

Composite and Ima ge Sequences that  fo llows this secti on.)  

Backgro und:  Select  one of th e available images  to be th e backgr ound color in th is 

combo box.  The rest  of the image planes are subtr acted fro m th e backgro und ima ge 

ð effect ively punching ñholesò into it  and al low ing the for egro und color s to show 

without  m ixing wit h the backgro und.  This is most  eff ect ive where the backgro und 

covers large areas and the oth er im ages have sm aller objects wi thin th e backgr ound 

objects. 

Backgro und allows the other inputs to be displayed ñin fro nt  ofò th e backgr ound 

inputs, m inim izing color m ixing. For example, ALTRAview  can d isplay a red dot on a 

blue backgro und without  turning the dot  to magenta. 

Select ing None causes al l ima ges to be equal ly m ixed. 

New:  Click on  the New button  to discard the curr ent  color composite ima ge, and start 

over. 

The Source I ma ges combo box wi ll reset  to include al l gr ay scale images ( including 

float ing point  ima ges) . Select ing an image fro m the list  wil l create a new composite 

th e same size as th e in iti al select ion. As me nt ioned previously, the source ima ges list 
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wi ll be filt ered to conta in only images of the sam e size as th e ini t ial select ion. 

12.7. Range Shift+R 

The Process> Range comm and allows set  the intensity  levels of th e im age to 

increase the contr ast  and enhance the display in low- light  situ at ions.  Choose th e 

Range command to open the Range dialog.  

Two vert ical ma rk ers show the upper and lower lim it s of the intensity  levels. These 

markers can be moved with mouse through the drag and dr op meth od. For a color 

image, the histogram will reflect  the red, green, and blue values with corr esponding 

color s lines. 

 

Two Edit  cont rols indicate th e values of the in tensity levels.  Choose  th e spin but tons 

to increase or decrease these values.  All  values between 0 and the lower lim it  will be 

black and al l values between the upper lim it and the upper end of th e scale will be 

white.  These two edit  contro l values corr esponding to the tw o vert ical markers show 

th e upper and lower lim its of the intensity levels.  Defau lts are o and 255 respecti vely. 

Reset  The Reset  butt on allows Reset  th e black and whit e levels to th e high and 

low ends of the dy namic Range. 
 

 
Best Fit  

The Best  Fit  butt on aut oma ti cally sets th e int ensit y levels to th e Best  Fit . 

Best Fit instructs ALTRAview  to optim ize th e brightn ess and contr ast  values 

for th e parti cular ima ge. 

I nvert  The I nvert  butt on reverses th e color of th e image. 

 
Update 

Update  will refresh th e display Range  with th e most  current  ima ge 

informa ti on. 

12.8. Binary Shift+B 

Binary is a kind of gr ay level pro cess. I f the gray  of the pixel is gr eater th an the given 

threshold,  th e pixel's color will be changed in to white.  Otherw ise,  the pixel's color wi ll 

be changed into black. Although  the pro cess may lose some infor mat ion, it  is an 

important  step of oth er pro cesses. 
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The curve  on  th e Binary dialog shows the gr ay distr ibut ion  of th e image.  

The Line in the dialog indicates  the threshold value. Drag th e line to change th e 

threshold,  or  change the value in the Line position  edit  box ( in the top left  corner of 

th e dialog)  to move the Line. 

The Line posit ion  edit  box shows  th e curr ent  posit ion  value of the Line;  Modify the 

value wil l move th e Line at the sam e time;  

Click th e "Best  Fit"  butt on  to apply  the auto th reshold pro cess to the ima ge.  I t  uses 

an automat ic th reshold to make the ima ge Binary. 

12.9. Pseudo Color 

Note:  Ima ge m ust  be in Gray Scale. 

Choose th e Pseudo Color command to "color ize" the act ive monochromat ic image. 

This is used to highlight  certain feat ures in a gray scale ima ge such as display all 

densit ies above a certa in point  in red,  or, th e ima ging device record ed th ermal 

infor mati on, all temperatu res below a certain point  can be revealed in blue color. 

 

 
 

When Pseudo Color a monochromatic  ima ge,  a special palet te need to be bui ld wit h 

which the monochromat ic image is displayed.  Pseudo Color ing an image does not 

modify th e pixels' values in ima ge bitma p (it  does not  conv ert  image to true color or 

palet te). I t simply associates a Pseudo Color palet te with the ima ge th at in terpr ets 

th e gray- level values in the ima ge as color. 

Pseudo Colored images  are very sim ilar  in structure to palet te class images,  but  th ey 

diff er  in a couple of important  ways.  First , the pixels' values in a Pseudo Colored 
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image actually represent  cont inuous-tone in tensit y infor mat ion, whereas a palett e 

image's pixels carr y no in tensit y significance.  Secondly, a palette image includes a 

palet te table that  is actually part  of the image file.  

The colors used  to map th e gray values can be selected. The butt ons at each end 

of th e color str ips (              or   )  will br ing up th e color dialog separately, 

which allows select  th e start  and end colors of th e range. 

12.10. Surface Plot 

The Process>S urface Plot (or 3-D Plot)  tool creates a 3-D repr esentat ion of the 

in tensit y of an image.  When choosing  the Surf ace Plot  command,  keep in mind that 

X= image width and Y= image height , and Z=p ixel gr ay value. 

I n th e viewpoint  window, the elevati on  and ro ta ti on  of the ima ge can be adjusted by 

dragging the mouse on the ima ge. 

 

Position  Solid:  The left  edit  control  indicates the relative posit ion  of th e ent ire ima ge 

in the viewp oint  window, whose default  value is 0.5.  The r ight  edit  contro l indicates 

th e relati ve height  of the display of the Z scale, whose default  value is 1. 

Reset :  Set  th e Posit ion Solid's two edit  controls  to their default  values. 

I ma ge Backgr ound Color:  Choose this command  to display a color dialog where one 

can adjust  the backgro und color of the viewpo in t  window. 

Capture:  Captu re the act ive image in the  viewpoint  wi ndow as a new ima ge.  
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Color Table:  Select  th e color s to m ap the gray values found in th e surface plot . The 

but ton  at  each end of the color table br ings up the color dialog,  which allows select 

th e start  and end colors of the range. (Please refer to Pseudo Color for more 

infor mati on) 

12.11. Line Profile 

Choose the Process> Line Pro file command  to il lustr ate how pixels along a 

selected line are distr ibuted by gr aphing th e number of pixels at  each color in tensit y 

level.  

 

Choose th e Measurem ents>Ar bit rary Line, or Measurem ents> Horizonta l Line or 

Measurements>  Vert ical Line command to draw a line on the image and choosing the 

Process>L ine Prof ile will br ing up a Line Pro file dialog as below(The pro cedure can be 

inv ersed) :  

 

Line Prof ile:  I n a Line Pro file, the X-axis  repr esents the spat ial scale,  and the Y-axis 

repr esents the in tensit y values which range fro m 0 to 255.  I f the image is a gray 

scale ima ge, the gr ay value will be pro filed. I f the ima ge is a HSV color ima ge,  the 

R,G and B values will be pro filed separately wit h th e corr esponding R, G and B 

color s. 

Backgro und:  Open the window s color dialog to set  the backgr ound color of the pro file 

window;  

Tit le:  Use this command  to set  a t it le on the Line Prof ile image;  

Capture:  Captu re the ima ge in the  Line Prof ile wi ndow as a new unti tl ed image;  




















































































